Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - ponysay-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ponysay-git 3.0.2.r2353-1

Git Clone URL: https://aur-dev.archlinux.org/ponysay-git.git (read-only)
Package Base: ponysay-git
Description: Cowsay reimplementation for ponies.
Upstream URL: https://github.com/erkin/ponysay
Licenses: GPL2, FDL
Conflicts: ponysay, ponysay-git
Provides: ponysay
Submitter: gtmanfred
Maintainer: Jristz (maandree)
Last Packager: Jristz
Votes: 7
Popularity: 0.000000
First Submitted: 2012-05-10 19:41
Last Updated: 2016-08-29 06:16

Dependencies (5)

Required by (2)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

maandree commented on 2012-08-26 23:53

Currently DESTDIR is 'make' has no effect, use --dest-dir in './configure' instead.

maandree commented on 2012-08-25 23:47

The line

optdepends=('util-say: tty2colourfultty and ponysay2ttyponysay')

should be changed, 'tty2colourfultty and ponysay2ttyponysay' is not a description of purpose, just a list of used executables.
I suggest changing it to 'util-say>=2: Improved TTY support utilising KMS support, and support for PNG files'

Also specifying 'util-say>=2' rather than 'util-say' is important, as 'util-say<2' uses the cowsay format in the ponysay utils,
while 'util-say>=2' uses the new format in 'ponysay>=2.1'.

gtmanfred commented on 2012-08-25 16:59

python is python3

coreutils fine, specifying both texinfo and gzip is redundent

as is make and bash, make is in base-devel, and requires sh, bash is the provider of sh in the repos

maandree commented on 2012-08-25 16:27

Correct dependency list::

REQUIRED FOR RUNTIME:
python>=3
coreutils

OPTIONAL FOR RUNTIME:
util-say>=2: Improved TTY support utilising KMS support, and support for PNG files

MAKE DEPENDENCIES:
gzip
texinfo
info
make, bash, sed, coreutils (for ponysay 2.5 python>=3 may be used instead with sh and make as optional)
git (if pkgbuild clones git repo)

Jristz commented on 2012-08-24 03:52

er, ponysay is a 'any' package, a python script and 250 ponies (text) only, none to build

Jristz commented on 2012-08-24 03:26

./dependency-test.sh
line 33 and 34, wath say? oh, Missing tty2colourfultty, install util-say [runtime optional], aka optdep, now know this I left the really final decition of adding or not the optdep

gtmanfred commented on 2012-08-24 01:49

the -f option does not require util-say so i am not including that, and I am not going to include every option, if you want pdf, edit the pkgbuild and add --with-pdf

gtmanfred commented on 2012-08-24 01:49

the -f option does not require util-say so i am not including that, and I am not going to include every option, if you want pdf, edit the pkgbuild and add --with-pdf

gtmanfred commented on 2012-08-24 01:43

i don't even know what that says

gtmanfred commented on 2012-08-24 01:40

i don't even know what that says