Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - ponysay-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ponysay-git 3.0.2.r2353-1

Git Clone URL: https://aur-dev.archlinux.org/ponysay-git.git (read-only)
Package Base: ponysay-git
Description: Cowsay reimplementation for ponies.
Upstream URL: https://github.com/erkin/ponysay
Licenses: GPL2, FDL
Conflicts: ponysay, ponysay-git
Provides: ponysay
Submitter: gtmanfred
Maintainer: Jristz (maandree)
Last Packager: Jristz
Votes: 7
Popularity: 0.000000
First Submitted: 2012-05-10 19:41
Last Updated: 2016-08-29 06:16

Dependencies (5)

Required by (2)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

gtmanfred commented on 2012-09-01 16:03

also.... do not use flag Out-of-date unless it is out of date, otherwise use the comments to mention your problems with it being broken

gtmanfred commented on 2012-09-01 15:57

zetaron but you flagged it out of date, again... after I update the pkgbuild and unflagged it

Anonymous comment on 2012-09-01 15:56

becouse yesterday the PKGBUILD was still broken... and since there is no button to flag the PKG as broken I used the out of date flag, to push the situation ;) please don't hate me for that I just couldn't live without my bash ponies anymore ;(

gtmanfred commented on 2012-09-01 01:29

why is this being marked out of date...

gtmanfred commented on 2012-08-29 18:35

I will fix it tonight

Jristz commented on 2012-08-29 18:23

configure was removes in this morning
change the configure to the suggested if have problems go to issue 94

gtmanfred commented on 2012-08-27 15:53

Hibernate, you do not include any dependencies from base-devel

make is in base-devel and it depends on sh, therefore you do not need to specify those

maandree commented on 2012-08-27 15:38

The first paragraph in last comment has been resolved.

maandree commented on 2012-08-27 13:56

DESTDIR has lost effect in 'make install', because it no uses a python script,
and the Makefile has not yet forward that configuration to the python script.
Until such time, --dest-dir must used instead in ./configure

However I would recommend using:

build()
{ ./setup.py --everything --without-pdf-compression build
}

package()
{ ./setup.py --everything --without-pdf-compression --dest-dir="$pkgdir" prebuilt
}

(this also loses three dependences: sh, sed, make)

gtmanfred commented on 2012-08-26 23:57

it has no effect until you do make install, then it uses INSTALLDIR... which uses DESTDIR