Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - plex-media-player

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: plex-media-player 1.2.2-1

Git Clone URL: https://aur-dev.archlinux.org/plex-media-player.git (read-only)
Package Base: plex-media-player
Description: Next generation Plex Desktop Client
Upstream URL: https://github.com/plexinc/plex-media-player
Licenses: GPL
Submitter: TingPing
Maintainer: degeberg
Last Packager: degeberg
Votes: 29
Popularity: 4.674665
First Submitted: 2015-11-29 18:10
Last Updated: 2016-12-31 13:40

Latest Comments

1 2 3 4 5 6 ... Next › Last »

suridaj commented on 2017-01-31 15:22

Hi @varble, the new conan 0.19 is out. The build should work with gcc 6.3 out of the box, if you try it out please let me know if there were any problems.

suridaj commented on 2017-01-26 14:11

@varble, the next release of conan will support gcc 6.3 out of the box without the need to add it manually to the list of recognized compilers.

varble commented on 2017-01-22 06:39

Building fails with this error:

ERROR: '6.3' is not a valid 'settings.compiler.version' value.
Possible values are ['4.4', '4.5', '4.6', '4.7', '4.8', '4.9', '5.1', '5.2', '5.3', '5.4', '6.1', '6.2']
Check your settings ~/.conan/settings.yml or read the docs FAQ

I bypassed this and got a successful compile by editing ~/.conan/settings.yml and appending 6.3 to the end of the version check string, which references the newest gcc version.

lukeab commented on 2017-01-08 23:45

I managed to resolve the issue, i had to push pacaur for small patch updates specifically from AUR for python-[node-semver,fasteners,patch,monotonic]

for somereason i kept getting similar errors as below, once i followed the resulting errors each time and running `pacaur -u python-[xxxx]` it worked.

lukeab commented on 2017-01-08 22:35

I keep running into a build error with conan adding the remote

...
Starting prepare()...
-> Checking for plex conan remote
Traceback (most recent call last):
File "/usr/bin/conan", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3019, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3003, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3032, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 655, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 963, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 849, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'fasteners>=0.14.1' distribution was not found and is required by conan
-> Adding https://conan.plex.tv as a conan remote
Traceback (most recent call last):
File "/usr/bin/conan", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3019, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3003, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3032, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 655, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 963, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 849, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'fasteners>=0.14.1' distribution was not found and is required by conan
==> ERROR: A failure occurred in prepare().
Aborting...

TiTan4T commented on 2017-01-08 03:16

Everything works fine, but when I want to leave the app, I can just choose restart or cancel !?

degeberg commented on 2016-12-31 13:40

Done.

hashworks commented on 2016-12-31 11:28

This builds on armv7h, could you add it?

batpets commented on 2016-12-28 19:34

Absolutely same outputs. Reinstalling didn't help. Error still exist. Upgrade plex-mediap-layer package trough yaourt, but nothing.

degeberg commented on 2016-12-27 22:10

@batpets: Does /usr/lib/libp8-platform.so.2 exist on your system? Perhaps try reinstalling p8-platform. On my system, I get:

$ pacman -Ql p8-platform | grep '\.so'
p8-platform /usr/lib/libp8-platform.so
p8-platform /usr/lib/libp8-platform.so.2
p8-platform /usr/lib/libp8-platform.so.2.1.0

$ ls -l /usr/lib/libp8-platform.so*
lrwxrwxrwx 1 root root 19 Oct 26 13:18 /usr/lib/libp8-platform.so -> libp8-platform.so.2
lrwxrwxrwx 1 root root 23 Oct 26 13:18 /usr/lib/libp8-platform.so.2 -> libp8-platform.so.2.1.0
-rwxr-xr-x 1 root root 50472 Oct 26 13:18 /usr/lib/libp8-platform.so.2.1.0

$ md5sum /usr/lib/libp8-platform.so*
5dd534a139e2cc45690d18e7030dd6ce /usr/lib/libp8-platform.so
5dd534a139e2cc45690d18e7030dd6ce /usr/lib/libp8-platform.so.2
5dd534a139e2cc45690d18e7030dd6ce /usr/lib/libp8-platform.so.2.1.0