Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - pia-tools

Package Details: pia-tools 1.1.1-1

Git Clone URL: https://aur-dev.archlinux.org/pia-tools.git (read-only)
Package Base: pia-tools
Description: OpenVPN hook for privateinternetaccess.com
Upstream URL: https://github.com/pschmitt/pia-tools
Keywords: PIA VPN
Licenses: GPL3
Submitter: ethanmad
Maintainer: pschmitt
Last Packager: pschmitt
Votes: 10
Popularity: 0.305412
First Submitted: 2015-08-19 01:39
Last Updated: 2017-02-04 10:45

Latest Comments

jikbag commented on 2016-03-21 05:49

sha256sum is broken for me too. I'm getting the same 2f111701 pia-tools-1.0.tar.gz as Big-B.

Rick100 commented on 2016-03-19 19:21

/usr/bin/pia-tools:256

change from:
unzip -d "$PIA_CONFIG_DIR" "$PIA_CONFIG_DIR/openvpn.zip"
to
unzip -d "$PIA_CONFIG_DIR" "$PIA_CONFIG_DIR"/openvpn.zip

to avoid
$pia-tools --setup
Updating configuration...
unzip: cannot find or open , .zip or .ZIP.
Done!

Big-B commented on 2016-03-15 01:37

sha256sum should be:
2f111701eec8508bc44fd32f237fb3f716b330c8132cdca4bd682ecd5f7589fd

linuxista commented on 2016-03-14 14:50

Validating source files with sha256sums...
pia-tools-1.0.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!

johnwallaby commented on 2016-03-13 09:51

hi, unfortunately the pkg does not build --> failed to verify pia-tools integrity.

TheOneJester commented on 2016-02-05 00:53

# vim /usr/bin/pia-tools

change line 256 to:

unzip -d "$PIA_CONFIG_DIR" "$PIA_CONFIG_DIR/openvpn.zip"

AllButOne commented on 2016-01-05 19:26

Wonderful, but I also had the unzip error this time, I had installed over year ago perfectly fine.
Recheck line 256 of pia-tools
I modified it "unzip -d /etc/openvpn/pia/ -q -o /etc/openvpn/pia/openvpn.zip" in usr/bin/pia-tools.
But it obviously won't update automatically via systemd this way.

motion_blur commented on 2015-09-18 09:50

Nice work!
There is an error with the unzipping, had to do it manually.
Maybe you also want to modify the .ovpn files afterwards for automatic autentification, e.g. add auth-user-pass auth.txt

ethanmad commented on 2015-08-20 05:40

pdean: I've made the change in the package.

pdean commented on 2015-08-19 17:10

replace dnsutils with bind-tools