Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: pi-hole-server 2.12.1-2

Git Clone URL: https://aur-dev.archlinux.org/pi-hole-server.git (read-only)
Package Base: pi-hole-server
Description: The Pi-hole is an advertising-aware DNS/Web server. Arch adaptation for lan wide DNS server.
Upstream URL: https://github.com/pi-hole/pi-hole
Keywords: ad block pi-hole
Licenses: GPL2
Conflicts: pi-hole-standalone
Submitter: max.bra
Maintainer: max.bra
Last Packager: max.bra
Votes: 13
Popularity: 2.236386
First Submitted: 2016-01-13 12:50
Last Updated: 2017-02-04 10:49

Pinned Comments

max.bra commented on 2017-01-01 17:24

Update to ver. 2.10.x need manual interaction:
delete /etc/dnsmasq.d/01.pihole.conf is needed before updating.

From ver. 2.10.x this package will manage the files in the folder dnsmasq.d/.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

max.bra commented on 2017-02-04 11:03

hi tsago,
thanks for reporting. done.

> Also, before I flushed, the graph in GUI was stuck on always showing the same day.
if i have well understood the observation: the dataset used for drawing that canvas collect data from pihole.log only and should show the time lapse between the first log timestamp and the last one. there is no "today filter" in the code...

edit: typo

tsago commented on 2017-02-04 09:35

Hi there! Looks like flushing with logrotate is broken.

# pihole -f
::: Flushing /run/log/pihole/pihole.log ...error: cannot stat /etc/pihole/logrotate: No such file or directory
... done!

Fixed by adding https://github.com/pi-hole/pi-hole/blob/master/advanced/logrotate into /etc/pihole/logrotate with path modified to /run/log/pihole/pihole.log.

Also, before I flushed, the graph in GUI was stuck on always showing the same day.

Did I do something wrong? Or is it arch-pihole specific? Or is it a general issue with the last version?

max.bra commented on 2017-01-19 08:19

Hi Chilloutman,
yes it is. Missed that. Thanks for reporting.

Chilloutman commented on 2017-01-19 07:14

During the installation "netstat" is used and on my system this caused some issues as it was not available.

After installing "net-tools" from core, the errors were fixed. Is "net-tools" a missing dependency?

tdkl commented on 2017-01-14 21:42

@max.bra: no I use lighttpd
@C0rn3j: if you mean the js console inside the browser, there were none.

I've installed 2.9.5 back from AUR, works without issues. Too much hassle at constant changes for each update, so I'll keep it at this version.

C0rn3j commented on 2017-01-12 10:29

@tdkl Check the javascript console for errors

max.bra commented on 2017-01-12 07:31

It seemed like a good start :-P

C0rn3j commented on 2017-01-11 23:57

Taillog is fine for me over HTTPS, so it must be a different issue ^^

max.bra commented on 2017-01-11 23:37

hi tdkl,
all functional here.
if I remember correctly, are you using nginx?
maybe via https: https://github.com/pi-hole/pi-hole/issues/1100

tdkl commented on 2017-01-11 15:55

I've noticed that the query logs aren't displayed anymore. Am I only one with this issue ? I've reinstalled pihole freshly from AUR, but there's still no logs seen in the admin panel.