Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - phoenix-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: phoenix-git r1270.f77e221-6

Git Clone URL: https://aur-dev.archlinux.org/phoenix-git.git (read-only)
Package Base: phoenix-git
Description: A super-slick libretro frontend powered by Qt 5
Upstream URL: https://github.com/team-phoenix/Phoenix
Licenses: GPL
Conflicts: phoenix
Provides: phoenix
Submitter: Limero
Maintainer: Limero
Last Packager: Limero
Votes: 11
Popularity: 0.231158
First Submitted: 2015-10-25 21:47
Last Updated: 2016-07-02 19:45

Pinned Comments

Limero commented on 2016-06-28 22:43

Phoenix is currently moving from QMake to CMake. Until installed builds are working correctly, the PKGBUILD will grab the latest commit that used QMake.

Latest Comments

1 2 Next › Last »

igno2k commented on 2016-07-02 15:37

Thanks Limero - that's it!

Please add it to the dependencies.

Limero commented on 2016-07-01 20:47

igno2k, does it work if you install qt5-declarative? If so, I'll add it to dependencies.

igno2k commented on 2016-07-01 18:59

Getting the following error when starting the binary after the last update:

$ Phoenix
D 20:51:49:465 Library::PhxPaths::initPaths():124: Installed mode
D 20:51:49:466 main():85: Phoenix v0.0.1-pre-alpha-12-gf77e221
W 20:51:49:486 unknown():0: QQmlApplicationEngine failed to load component
[unknown:0 unknown()]
W 20:51:49:486 unknown():0: qrc:/Phoenix/Phoenix.qml:3 module "QtQuick.Layouts" is not installed

[unknown:0 unknown()]

-------------

Anyone can help?

Limero commented on 2016-06-28 22:43

Phoenix is currently moving from QMake to CMake. Until installed builds are working correctly, the PKGBUILD will grab the latest commit that used QMake.

athairus commented on 2016-06-28 17:25

Hey Limero. This PKGBUILD needs an update since we changed build systems to CMake. Come on IRC, we need to figure out a better way to contact you...

gee commented on 2016-06-06 00:06

Thank you for the change!

gee commented on 2016-06-03 05:13

Oh unrelated to my previous comment, I think it would make sense to have the
git submodule update --init --recursive
line outside of build and maybe in prepare instead.
I'm mostly thinking that because when I was debugging the build failure, I did makepkg -o and yet I didn't get all the files needed which took me some time to understand...

Thanks!

gee commented on 2016-06-02 21:11

I've created a bug for this upstream, we'll see how it goes.

Though until a fix gets upstream, a user that wants to build phoenix will need to patch anyway ;)

edit: it's upstreamed!

Limero commented on 2016-06-02 21:08

@gee You should try to get it added upstream. We shouldn't add our own patches unless we really need to.

gee commented on 2016-06-02 21:04

In case you're as annoyed as I was to get the patches in the correct line ending, here's my source tarball:
https://mega.nz/#!k85E1AgJ!AT7UX0Bm9XuQ5zCwpmv_XMpIV0CGcQqCT450iFLopPs