Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - pgl-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: pgl-git 2.3.1.1.r32.g13f606f-1

Git Clone URL: https://aur-dev.archlinux.org/pgl-git.git (read-only)
Package Base: pgl-git
Description: A privacy oriented firewall application (Daemon, CLI & GUI).
Upstream URL: http://sourceforge.net/projects/peerguardian/
Licenses: GPL3
Conflicts: pgl, pgl-cli
Provides: pgl
Submitter: Gilrain
Maintainer: Gilrain
Last Packager: Gilrain
Votes: 1
Popularity: 0.001082
First Submitted: 2013-05-18 12:53
Last Updated: 2016-01-14 14:38

Latest Comments

glitsj16 commented on 2016-01-02 04:20

As of http://sourceforge.net/p/peerguardian/code/ci/c3b264f25f33f7f0ace5a5a1c2b4b3c0db11f758/ pglgui has been ported to Qt5. Hence this PKGBUILD needs updating to drop qt4 and polkit-qt4 dependencies and replace those by qt5-base. Also, the qt4 vars exported in build() need to be dropped.

PKGBUILD with the needed changes is available at https://gist.github.com/glitsj16/0a0a02854b0b12a56ad4

Zaban commented on 2015-06-29 09:09

-> Adding install file...
-> Generating .MTREE file...
-> Compressing package...
/usr/bin/makepkg: line 2183: /tmp/yaourt-tmp-blabla/PKGDEST.847/pgl-git-debian/2.3.0.1.r11.g6cf53bc-1-x86_64.pkg.tar.xz: No such file or directory
bsdtar: etc/dbus-1/system.d/org.netfilter.pgl.conf: Write error
==> ERROR: Failed to create package file.
==> ERROR: Makepkg was unable to build pgl-git.