Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: pdfbeads 1.1.1-4

Git Clone URL: https://aur-dev.archlinux.org/pdfbeads.git (read-only)
Package Base: pdfbeads
Description: A small utility written in Ruby which takes scanned page images and converts them into a single PDF file
Upstream URL: http://rubygems.org/gems/pdfbeads
Licenses: GPL
Submitter: Blender
Maintainer: None
Last Packager: c-mauderer
Votes: 5
Popularity: 0.000019
First Submitted: 2012-01-29 19:23
Last Updated: 2015-06-11 20:08

Latest Comments

c-mauderer commented on 2016-12-03 11:38

Since the packet has problems again and I'm really not that deep into Ruby I decided to disown the packet. Maybe someone with more Ruby experience is able to find a permanent patch. Fell free to take over.

c-mauderer commented on 2014-10-13 18:49

It seems that the problem is related to a missing dependency which is a build dependency of imagemagick: openjpeg2. Therefore rebuilding a imagemagick helped while it would have been enough to install openjpeg2. I've added the package to the dependencies.

Please tell me If you still get a problem that pdfbeads just hangs for several minutes (more than 5 to 10). I can't promise anything but I would try to invest some more time in finding the bug.

c-mauderer commented on 2014-10-11 11:54

Please note that there seems to be a problem with the official imagemagick package at the moment.

If the "extra/imagemagick 6.8.9.7-1" is used, pdfbeads just hangs without generating any output. I had to use "aur/imagemagick-no-hdri 6.8.9.8-1" instead.

Please don't forget to rebuild ruby-rmagick if you update your imagemagick.

I will try to find the bug and report it back. But I can't promise anything.

c-mauderer commented on 2014-04-26 08:55

Sonds more like a problem with ruby-rmagick. From your message I would assume that you have to rebuild ruby-rmagick every time a new ImageMagick is installed. I don't think that I can do anything about that within this package.

jmartl109 commented on 2014-04-26 05:51

I'm getting:
/usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': This installation of RMagick was configured with ImageMagick 6.8.8 but ImageMagick 6.8.9-0 is in use. (RuntimeError)

To fix this, I rebuilt ruby-rmagick.

jmartl109 commented on 2014-04-25 23:21

I'm getting:
/usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': This installation of RMagick was configured with ImageMagick 6.8.8 but ImageMagick 6.8.9-0 is in use. (RuntimeError)

c-mauderer commented on 2014-04-08 19:14

OK. Even if I have no experience with ruby, I'll take over the package. If anyone other would like to maintain it just ask.

Blender commented on 2014-04-07 21:38

I guess I missed that comment. I don't have much interest in this package, so I'm disowning it.

c-mauderer commented on 2014-04-07 19:47

I had to use the already mentioned --no-user-install flag for "gem install" command to build this package.

Beneath that, there seems to be a missing dependency: The program needs ruby-iconv to run.

Anonymous comment on 2013-07-17 13:54

Please add a --no-user-install flag to the gem install command. See https://wiki.archlinux.org/index.php/Ruby_Gem_Package_Guidelines