Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: parmetis 4.0.3.p2-1

Git Clone URL: https://aur-dev.archlinux.org/parmetis.git (read-only)
Package Base: parmetis
Description: A parallel graph partitioning library
Upstream URL: http://glaros.dtc.umn.edu/gkhome/metis/parmetis/overview
Licenses: custom
Submitter: jedbrown
Maintainer: jedbrown
Last Packager: jedbrown
Votes: 22
Popularity: 0.033367
First Submitted: 2008-05-15 20:41
Last Updated: 2016-02-11 01:02

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

capitalaslash commented on 2012-07-05 10:28

i'm sorry but i'm not talking about aesthetics here.
if metis is built separately and parmetis builds it inside and does not use the external one, configuration issues can arise easily.
i agree that this issue should be addressed by the parmetis build tools (the 4.0 version switch has not improved things, i'm very sorry to say).
will you update the PKGBUILD in order to list metis as a "depends" and not as a "provides"?

jedbrown commented on 2012-07-05 10:09

Parmetis "make install" does not install Metis. We have been using both with this dependency in PETSc for more than half a year (many users on different platforms) and this approach has been working fine. Talk to George if you think installation should be done differently. (I do, but he has not been responsive about applying patches for real portability issue, so it hasn't seemed worthwhile to press on more aesthetic issues.)

capitalaslash commented on 2012-07-05 09:56

i believe metis is built inside parmetis, the problem is that it not installed along with it.
adding metis as an external dependency can be dangerous if the configuration is not consistent.

jedbrown commented on 2012-07-05 09:52

Parmetis depends on Metis since the latest release. I just updated the package to add this dependency.

capitalaslash commented on 2012-07-05 08:10

with this configuration it does not install metis along with parmetis.
i've tried to do it myself and i'm able to install libmetis, but i cannot find a clean way to install metis.h.
how can you use it without metis?

jedbrown commented on 2012-05-16 12:50

done

jacopo_c commented on 2012-05-16 09:42

You should add openmpi between dependencies

jedbrown commented on 2011-08-11 18:53

Updated to 4.0, let me know if there are any problems.

Anonymous comment on 2011-08-06 11:27

Not working anymore. Please change:

source=(http://glaros.dtc.umn.edu/gkhome/fetch/sw/parmetis/ParMetis-$pkgver.tar.gz)
to
source=(http://glaros.dtc.umn.edu/gkhome/fetch/sw/parmetis/OLD/ParMetis-$pkgver.tar.gz)

Thanks!

kragacles commented on 2011-06-15 20:19

Great! Thanks much.