Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - paraview-bin

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: paraview-bin 5.2.0-2

Git Clone URL: https://aur-dev.archlinux.org/paraview-bin.git (read-only)
Package Base: paraview-bin
Description: ParaView is an open-source, multi-platform data analysis and visualization application
Upstream URL: http://www.paraview.org/
Licenses: custom
Conflicts: paraview
Provides: paraview
Submitter: Cadair
Maintainer: eolianoe
Last Packager: eolianoe
Votes: 5
Popularity: 1.323208
First Submitted: 2015-08-25 12:33
Last Updated: 2017-01-19 16:58

Pinned Comments

poconbhui commented on 2016-07-13 19:25

libgl drivers complain and fail because of an outdated libstdc++ in this package. You can see this by running
LIBGL_DEBUG=verbose paraview

Removing /usr/lib/paraview-*/libstdc++.so* does the trick. Should generally be fine to do since libstdc++ guarantees backwards compatability and ParaView is build with gcc 4. See http://www.paraview.org/Wiki/ParaView/Binaries (Outdated, but that still seems to be what they're using).

Latest Comments

1 2 Next › Last »

MartinDiehl commented on 2017-01-19 09:07

would it be possible to place a symlink from "${pkgdir}/opt/${_pkgname}/share/applications/paraview.desktop" to either /usr/share/applications or /usr/local/share/applications?

Than paraview would be visible in gnome etc (see https://wiki.archlinux.org/index.php/Desktop_entries)

revelation commented on 2016-10-09 06:16

@poconbhui: Thank you very much!
@eolianoe: Could you add something like
rm ${pkgdir}/usr/lib/paraview*/libstdc++.so*
to the PKGBUILD? - Thank you so much!

gdolle commented on 2016-09-08 12:40

The current md5sum is not updated

eolianoe commented on 2016-07-23 11:36

@poconbhui: Could you tell me precisely the driver you are using, in order to delete the files only with that driver installed.

poconbhui commented on 2016-07-20 13:01

@eolianoe: It's an issue with drivers loaded by libGL. I think I'm using the bog standard drivers, so I imagine this issue affects a good number of people. If your drivers don't look for libstdc++ newer than whatever g++ 4 provides (or at all), you probably won't have any issues.

eolianoe commented on 2016-07-15 10:27

@poconbhui: No need of this trick on my machine, so maybe it depends on your drivers.

poconbhui commented on 2016-07-13 19:25

libgl drivers complain and fail because of an outdated libstdc++ in this package. You can see this by running
LIBGL_DEBUG=verbose paraview

Removing /usr/lib/paraview-*/libstdc++.so* does the trick. Should generally be fine to do since libstdc++ guarantees backwards compatability and ParaView is build with gcc 4. See http://www.paraview.org/Wiki/ParaView/Binaries (Outdated, but that still seems to be what they're using).

nplatis commented on 2016-05-05 06:18

Validation error again, they probably updated their archive without changing the name. I now get:

c9b0410804e6ae0b8fe617fe96dd786b1b29c973477d7fadc3a1fbb24cf52daa ParaView-5.0.1-Qt4-OpenGL2-MPI-Linux-64bit.tar.gz

ram commented on 2016-02-22 15:00

I got a validation error with 5.0

==> Validating source files with sha256sums...
ParaView-5.0.0-Qt4-OpenGL2-MPI-Linux-64bit.tar.gz ... FAILED
License_v1.2.txt ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build paraview-bin.


Thanks for the package!

chriS04 commented on 2016-01-07 19:33


It's a permissions issue.
# chmod a+r /usr/lib/paraview-4.4/libGenericIO.so

Will fix it.