Package Details: panda3d 1.9.3-1

Git Clone URL: https://aur-dev.archlinux.org/panda3d.git (read-only)
Package Base: panda3d
Description: A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d.
Upstream URL: http://www.panda3d.org
Licenses: BSD
Submitter: wonder
Maintainer: croxis
Last Packager: croxis
Votes: 32
Popularity: 1.612378
First Submitted: 2010-01-30 22:41
Last Updated: 2016-12-26 18:50

Dependencies (47)

Required by (0)

Sources (2)

Latest Comments

croxis commented on 2016-10-17 14:54

Hamidreza, if you need more immediate support you can poke #panda3d on the freenode irc network.

<rdb> Yes, it's true that 1.9.2 doesn't officially support Python 3, but that's not the issue here, I think.
<croxis> I'm just forwarding the bug report upstream (here!) :P
<zauberparacelsus> ok
<rdb> croxis: it seems more likely that the ode version updated and therefore panda has to be rebuilt against the new ode version.
<croxis> He built panda with no ode
<rdb> That seems unlikely.
<rdb> Perhaps a file from an old build lingered?
<croxis> possible
<rdb> He should try deleting the panda3dOdeModules.py file.
<rdb> (This is handled much more elegantly in 1.10, by the way, where we no longer have a single PandaModules so ode would not be imported normally.

croxis commented on 2016-10-17 14:49

I can't check while at work, I referred this to upstream as well

Hamidreza commented on 2016-10-17 11:30

I compiled with python3 and --no-ode.
When I run python samples, I have error:
Traceback (most recent call last):
File "main.py", line 16, in <module>
from direct.showbase.ShowBase import ShowBase
File "/usr/share/panda3d/direct/showbase/ShowBase.py", line 30, in <module>
from direct.interval import IntervalManager
File "/usr/share/panda3d/direct/interval/IntervalManager.py", line 5, in <module>
from pandac.PandaModules import *
File "/usr/share/panda3d/pandac/PandaModules.py", line 44, in <module>
from .panda3dOdeModules import *
File "/usr/share/panda3d/pandac/panda3dOdeModules.py", line 3, in <module>
from panda3d.ode import *
ImportError: libode.so.4: cannot open shared object file: No such file or directory

abhisheietk commented on 2016-03-21 06:09

Thanks croxis
--no-ffmpeg worked...

abhisheietk commented on 2016-03-20 13:17

while compilation getting this error

panda/src/ffmpeg/ffmpegVideoCursor.cxx:94:33: error: 'PIX_FMT_BGR24' was not declared in this scope
PIX_FMT_BGR24, SWS_BILINEAR | SWS_PRINT_INFO, N

croxis commented on 2015-04-11 16:27

Note: there is experimental python3 support. Edit PKGBUILD to use python or python3

bkfox commented on 2014-04-06 12:07

Please, avoid the default 4 and 5 threads at build. Perhaps is it better to use nproc to select a number of threads corresponding to the number of cpu's cores.

isitsaturday commented on 2014-04-03 21:19

http://pastebin.com/pneJxbfc

croxis commented on 2014-02-11 21:03

Updated. Thanks.

2M1R commented on 2014-01-10 14:36

This is my pkgbuild with patch for panda_glxext.h and with freeglut dependency: http://www.sendspace.com/file/cca9tm

All comments