Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - paccache

Package Details: paccache 0.1.25-1

Git Clone URL: https://aur-dev.archlinux.org/paccache.git (read-only)
Package Base: paccache
Description: serve pacman cache and redirect via avahi service
Upstream URL: https://github.com/eworm-de/paccache
Licenses: GPL
Conflicts: pacserve
Replaces: pacserve
Submitter: eworm
Maintainer: eworm
Last Packager: eworm
Votes: 6
Popularity: 0.009079
First Submitted: 2013-10-29 09:53
Last Updated: 2016-12-21 22:24

Latest Comments

hsmalley commented on 2016-07-09 17:52

@miku84 I had the same problem. I installed the paccache package from another one of my systems when I was rebuilding my box. Looks like installing the package from chroot during my system build wasn't the best idea and broke paccache.

I reinstalled the dependencies using the --force option on pacman. Then it compiled with a problem. To install it I had to use the --force option again.

quick fix:

pacman -S avahi curl iniparser darkhttpd libmicrohttpd nss-mdns markdown --force

pacman -U paccache-0.1.20-1-x86_64.pkg.tar.xz --force

miku84 commented on 2015-10-23 08:38

pacredir.c:454:3: error: ‘MHD_create_response_from_data’ is deprecated [-Werror=deprecated-declarations]
response = MHD_create_response_from_data(strlen(page), (void*) page, MHD_NO, MHD_NO);
^
In file included from pacredir.h:35:0,
from pacredir.c:9:
/usr/include/microhttpd.h:2022:1: note: declared here
MHD_create_response_from_data (size_t size,
^
cc1: all warnings being treated as errors
Makefile:26: recipe for target 'pacredir' failed
make: *** [pacredir] Error 1
==> ERROR in the build()
==> ERROR: Makepkg was unable to build paccache.


I receive this error. How can I solve it?
Thanks!

miku84 commented on 2015-03-31 19:39

worked, thanks :)

eworm commented on 2015-03-31 18:28

gpg --recv-keys 54EDC91609BC9183

miku84 commented on 2015-03-31 15:48

Also cannot install
Not valid public key: 54EDC91609BC9183
How to solve?

eworm commented on 2015-03-26 17:57

% gpg --verify paccache-0.1.13.tar.xz.asc
gpg: assuming signed data in 'paccache-0.1.13.tar.xz'
gpg: Signature made Thu 19 Mar 2015 07:07:39 PM CET using RSA key ID 09BC9183
gpg: Good signature from "Christian Hesse <Christi@n-Hes.se>" [unknown]
gpg: aka "Christian Hesse <mail@eworm.de>" [unknown]
Primary key fingerprint: BD84 DE71 F493 DF68 14B0 1672 54ED C916 09BC 9183

Looks ok to me. ;) What exactly does your error look like?

hutou commented on 2015-03-26 14:14

Hi,
pgp key is invalid.
Cannot build.
Regards

hutou commented on 2015-03-26 14:14

dlin commented on 2014-03-24 05:32

Hi, Christian,

Maybe you could change the download link to
https://github.com/eworm-de/paccache/archive/0.1.2.zip
That's will save your time on put another download file in your personal site.
And that make sure consistent with your github repository.

Scimmia commented on 2013-11-18 21:23

shouldn't this be paccache-git? If you're pulling from master, that's the standard way of naming packages.