Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - ozone

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: ozone 4:2.22m-1

Git Clone URL: https://aur-dev.archlinux.org/ozone.git (read-only)
Package Base: ozone
Description: Segger Ozone JLink debugger for Linux
Upstream URL: https://www.segger.com/jlink-software.html
Licenses: custom
Groups: jlink
Conflicts: jlink-debugger
Provides: jlink-debugger
Replaces: jlink-debugger
Submitter: AlexisPolti
Maintainer: AlexisPolti
Last Packager: AlexisPolti
Votes: 7
Popularity: 0.402058
First Submitted: 2016-06-08 17:22
Last Updated: 2017-01-28 20:59

Required by (1)

Sources (2)

Latest Comments

AlexisPolti commented on 2016-12-30 19:44

@ivanovp : sorry my mistake. Corrected!

ivanovp commented on 2016-12-29 16:44

Does not compile for i686. Fixed md5sum:
md5sums_i686=('e406bcf349977534179e8f2569e76448')

AlexisPolti commented on 2016-08-29 18:58

The bug should be corrected. The fix is quick and dirty and issues a lot a warnings. But as I'm now celebrating a birthday (and quite drunk) that's the best I can do for now.

If you have a better mean to do it right, please feel free to send it!

Alex :)

AlexisPolti commented on 2016-08-29 18:17

Oops, sorry! I'm correcting this right away.
Thanx for the feedback :)

GeirThomassen commented on 2016-08-29 18:13

Great work!

One small problem, an ordinary user can't read the register definition files:

$ ls -l /opt/SEGGER/Ozone/Config
total 8
drwx------ 2 root root 4096 Aug 24 10:25 CPU
drwx------ 2 root root 4096 Aug 24 10:25 Peripherals

The debugger starts as usual, but emits this error message:

Project.AddSvdFile ("ARM7.svd");
Project.AddSvdFile ("ARM7.svd"): invalid filename
File.Open: completed in 110 ms

AlexisPolti commented on 2016-06-08 17:50

This package is now deprecated. You should install Ozone instead.

AlexisPolti commented on 2016-03-03 00:36

On a second thought : you're saying that if I keep epoch > 0, any 2.14x will be considered newer as 2.14 ? I'll test it tomorrow. Thanx for the tip :)

BTW (as I'm quite new to Arch packaging), what's the problem with incrementing epoch ?

AlexisPolti commented on 2016-03-03 00:30

Sadly Segger released their first version as 2.14. And for AUR packaging system, 2.14a is a downgrade regarding 2.14. So I had to resort to epoch to force 2.14x to be newer as 2.14.

If you have a better idea, please don't hesitate, I searched a lot but didn't find anything better than this.

hzy199411 commented on 2016-03-03 00:20

I think you should not change epoch so frequently. beacuse version 2.14c > 2.14b, so you don't need update the epoch.