Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - openvpn-obfs

Package Details: openvpn-obfs 2.3.6-2

Git Clone URL: https://aur-dev.archlinux.org/openvpn-obfs.git (read-only)
Package Base: openvpn-obfs
Description: OpenVPN binary with obfs patch
Upstream URL: https://www.gsea.com.cn/blog/topic/traffic-obsfucate-patch-for-openvpn/
Licenses: custom
Submitter: wzyboy
Maintainer: wzyboy
Last Packager: wzyboy
Votes: 4
Popularity: 0.001477
First Submitted: 2013-03-13 13:21
Last Updated: 2015-06-08 11:16

Latest Comments

1 2 Next › Last »

wzyboy commented on 2014-12-03 09:11

@kokoko3k I've modified the patch. The issue should be fixed now. Thanks for notification.

kokoko3k commented on 2014-12-03 08:49

For some reason it wont work here:
Options error: Unrecognized option or missing parameter(s) in [CMD-LINE]:1: obfs-salt (2.3.6)
and:
Options error: Unrecognized option or missing parameter(s) in [CMD-LINE]:1: obfs-padlen (2.3.6)
..it seems not to recognize the obfs parameters

But works OK in 2.3.5

kokoko3k commented on 2014-12-03 08:45

For some reason it wont work here:

Options error: Unrecognized option or missing parameter(s) in [CMD-LINE]:1: obfs-salt (2.3.6)
and:
Options error: Unrecognized option or missing parameter(s) in [CMD-LINE]:1: obfs-padlen (2.3.6)

..it seems not to recognize the obfs parameters

kokoko3k commented on 2014-12-03 08:12

For some reason it wont work here:

Options error: Unrecognized option or missing parameter(s) in [CMD-LINE]:1: obfs-secret (2.3.6)

..it seems not to recognize the obfs parameters

Fetzz commented on 2014-10-12 17:03

Hey thanks for the work, for some reason the path to the tar.gz on openvpn.net in the PKGBUILD produces a time-out during the setup process.

I had to download it manually and change the PKGBUILD to have it all locally. makepkg -s worked then.

... is this just me?

wzyboy commented on 2013-08-31 08:54

Changed log level, thanks to https://gist.github.com/pentie/b1d5d75cdbc47b53bf9b .

wzyboy commented on 2013-06-01 01:25

@felixonmars: updated. Now this package is more closer to RFC than official core/openvpn.

felixonmars commented on 2013-06-01 00:52

Please install the binaries into /usr/bin/ instead of /usr/sbin/, according to the latest RFC. Also don't forget to update the paths in systemd unit, thanks!

wzyboy commented on 2013-05-31 16:32

@felixonmars: systemd unit added.

felixonmars commented on 2013-05-30 12:29

I would like to suggest a systemd unit to be placed under /usr/lib/systemd/system/openvpn-obfs@.service

[Unit]
Description=OpenVPN connection to %i
After=network.target

[Service]
Type=forking
ExecStart=/usr/sbin/openvpn-obfs --cd /etc/openvpn --config /etc/openvpn/%i.conf --daemon openvpn-obfs@%i

[Install]
WantedBy=multi-user.target