Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: openchange 2.3-7

Git Clone URL: https://aur-dev.archlinux.org/openchange.git (read-only)
Package Base: openchange
Description: A portable, open source implementation of Microsoft Exchange server and Exchange protocols.
Upstream URL: http://www.openchange.org
Licenses: GPL3
Submitter: a1russell
Maintainer: Zrax (DJ_L)
Last Packager: Zrax
Votes: 28
Popularity: 0.007703
First Submitted: 2010-08-20 16:19
Last Updated: 2016-06-03 16:20

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

Anonymous comment on 2013-06-10 08:46

I got same errors while installing openchange

./autogen.sh: running autoconf
configure.ac:8: error: possibly undefined macro: AC_DEFINE
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
==> ERROR: A failure occurred in build().
Aborting...

After some digging I find that I am missing pkg-config package, installing this package and running the setup again works perfect..

Sherif

Zrax commented on 2013-06-04 03:57

Fixed.

Anonymous comment on 2013-06-03 22:45

openchange /usr/sbin/
openchange /usr/sbin/openchange_newuser
openchange /usr/sbin/openchange_provision

These must now be in /usr/bin

Zrax commented on 2013-04-22 16:58

billycongo: I can't reproduce the issue you're seeing, but try the new 2.0 version I just uploaded and see if it works better.

billycongo commented on 2013-04-19 05:17

Getting this error:

./autogen.sh: running autoconf
configure.ac:8: error: possibly undefined macro: AC_DEFINE
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
==> ERROR: A failure occurred in build().
Aborting...

Zrax commented on 2013-02-08 02:58

NOTE: Although 2.0 is released, I am holding openchange at 1.0 for now, as evolution-mapi does not seem to compile against 2.0 yet. Once evolution-mapi upstream supports openchange-2.0, I will re-upload the 2.0 (or later, if necessary) package.

Zrax commented on 2013-01-25 01:49

makepkg will not automatically install AUR dependencies; only deps from the official repos will get automatically pulled in by pacman (at least, that's how it worked last time I checked). As for the package name, it was originally a single, monolithic package (named samba4), but I have more recently restructured it to provide the same 3 packages that the official repo's version of samba provides. The base package name is still samba4 to avoid confusion with the version in [community], but it provides the "samba>=4.0" package. If you still have an older version of samba4 (or samba-3.x) installed, you will need to update it before installing openchange 1.0-7.

Anonymous comment on 2013-01-24 20:02

After fixing the depends issues in the PKGBUILD file, I was then getting build errors because configure was unable to find python-config, once I linked python-config to python2-config in /usr/bin I was able to get it to configure as expected..

Anonymous comment on 2013-01-24 17:03

If I change the depends line from samba>=4.0.0-2 to "samba4" it targets samba4 as it should, it's thinking "samba" is the package name in the current depends line which does not exist at the 4.0.0-2 or greater version in either AUR or the official repositories. So it fails..maybe samba4 isn't providing "samba"?

Anonymous comment on 2013-01-24 16:54

The PKGBUILD file needs to read samba4 as a requirement then, unless I have something configured incorrectly..it's not automatically targeting samba4 because samba4 is not samba