Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - openblas-lapack

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: openblas-lapack 0.2.19-1

Git Clone URL: https://aur-dev.archlinux.org/openblas-lapack.git (read-only)
Package Base: openblas-lapack
Description: Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
Upstream URL: http://www.openblas.net/
Licenses: BSD
Conflicts: blas, cblas, lapack, lapacke, openblas
Provides: blas=3.6.0, cblas=3.6.0, lapack=3.6.0, lapacke=3.6.0, openblas
Submitter: sftrytry
Maintainer: eolianoe
Last Packager: eolianoe
Votes: 42
Popularity: 1.992333
First Submitted: 2013-11-20 23:53
Last Updated: 2016-12-19 10:52

Required by (189)

Sources (1)

Latest Comments

1 2 3 Next › Last »

chicomag commented on 2016-12-18 02:35

It builds successfully in armv7h arch, so, it's worth adding this target.

flocke commented on 2016-09-06 08:08

Alright, found my mistake. Rebuilding python-scipy-openblas failed because I forgot to rebuild python2-numpy-openblas and scipy also wants to build the pyton2 version in one go.

eolianoe commented on 2016-09-05 12:46

@flocke: I removed because it seems to be unused by the project and that it enforces the soname of the library. Now, the soname is only enforces by the compilation.
You just need to rebuild the packages depending on openblas-lapack.

flocke commented on 2016-09-05 07:43

Any reasons why you removed the 'MAJOR_VERSION=3' part from the PKGBUILD?
Anything linked against libopenblas.so.3 will fail after the update to 0.2.19 (e.g. python-scipy-openblas).

eolianoe commented on 2016-05-30 18:57

@buzz777: I know that there is some troubles with `USE_OPENMP=0` or `=1` depending on the application, see the comments below. If you do not like the choice in the PKGBUILD, just change it and rebuild. I do not have so much time to make full tests in various OpenMP applications, but I will try to investigate it.
The README is not mine it is the one of the upstream developers, if you have trouble with it, fill a bug report upstream.

buzz777 commented on 2016-05-30 18:32

Changing PKGINFO to USE_OPENMP=1 still produces incorrect build of openblas, and error is still there:

OpenBLAS Warning : Detect OpenMP Loop and this application may hang. Please rebuild the library with USE_OPENMP=1 option.
OpenBLAS Warning : Detect OpenMP Loop and this application may hang. Please rebuild the library with USE_OPENMP=1 option.

Please fix this or update readme with proper information on how to compile OpenBlas with OpenMP.

dekece commented on 2016-04-30 09:47

I tried it with https://aur.archlinux.org/packages/python-spams-svn/ and using openmp, but still have issues of cpu and fans going while for seemingly no reason. The single threaded version works fine (and the library itself is multithreaded with openmp) so it might still have issues.

dekece commented on 2016-04-30 05:34

Great, I will try enabling it on my side then to see if everything works fine. I do remember that older versions (maybe < 0.2.12 let's say) would something just hang in conflict with other openmp stuff and just deadlock there, but it should be 'fixed' (in the sense that ubuntu did backport it, but even that would still not work on my work computer), so hopefully the latest release will work on my personal laptop.

eolianoe commented on 2016-04-28 07:49

@berquist & @dekece: I disable it sometimes ago because I had trouble within a OpenMP application. I will make some new tests and enable it if it works fine in all configurations.

berquist commented on 2016-04-27 19:31

@dekece I have been using my own PKGBUILD with `USE_OPENMP=1` for quite some time and have never had any problems with it.