Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - openage-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: openage-git v0.3.0.r160.g6b8ff36-1

Git Clone URL: https://aur-dev.archlinux.org/openage-git.git (read-only)
Package Base: openage-git
Description: A free (as in freedom) clone of the Age of Empires II engine
Upstream URL: http://openage.sft.mx/
Keywords: aoe game
Licenses: GPL3
Conflicts: openage
Provides: openage
Submitter: linkmauve
Maintainer: fzerorubigd
Last Packager: fzerorubigd
Votes: 6
Popularity: 0.002100
First Submitted: 2015-03-23 17:01
Last Updated: 2016-01-22 22:04

Pinned Comments

fzerorubigd commented on 2016-03-18 10:35

This is the game engine only package. for assets you need the original game, and also need to use extractor to extract them. check the https://github.com/SFTtech/openage for the extraction doc.

Latest Comments

1 2 Next › Last »

benneti commented on 2017-01-21 22:45

I think dependencies should be updated to include qtquick:
depends=('python' 'libgl' 'libepoxy' 'ftgl' 'fontconfig' 'freetype2' 'harfbuzz' 'sdl2' 'sdl2_image' 'opusfile' 'opus-tools' 'ttf-dejavu' 'qt5-declarative' 'qt5-quickcontrols')
makedepends=('git' 'cmake' 'python-pillow' 'gcc' 'cython' 'python-pygments' 'python-numpy' 'opus-tools')

and maybe you could add the following to the PKGBUILD to fix some issues
probably best in package():
# Fix install problem (/usr/lib64 is a symlink)
mv $pkgdir/usr/lib64/* $pkgdir/usr/lib/
rmdir $pkgdir/usr/lib64
cp "$srcdir/$_pkgbase/run" $pkgdir/usr/bin/openage
propably in post_install()
# Fix missing files on startup
mkdir -p ~/.openage
mkdir -p ~/.openage/assets
cp -R /usr/share/openage/* ~/.openage/assets

electricprism commented on 2016-12-12 05:49

error: failed to commit transaction (conflicting files)
openage-git: /usr/lib64 exists in filesystem

janisozaur commented on 2016-12-11 22:14

I think this package needs updating, it tries to install to /usr/lib64 which for some reason causes filesystem (the package) to fail its transaction and on subsequent initcpio remake it prevents the system from booting due to missing /init.

arch-chroot'ing from live USB, removing openage-git then reinstalling packages: "filesystem systemd linux" fixes it, for anyone having the same issue.

rhoit commented on 2016-08-26 16:16

you need to add these in dependencies

python-astroid
python-isort
python-lazy-object-proxy
python-mccabe
python-wrapt
python-pillow
python-pylint
qt5-quickcontrols

rhoit commented on 2016-08-26 14:23

gives error while installing had to force install to solve this.
error: failed to commit transaction (conflicting files)
openage-git: /usr/lib64 exists in filesystem

janisozaur commented on 2016-05-30 13:11

with https://github.com/SFTtech/openage/pull/422 now merged, this package probably needs a lot more qt dependencies added.

fzerorubigd commented on 2016-03-18 10:35

This is the game engine only package. for assets you need the original game, and also need to use extractor to extract them. check the https://github.com/SFTtech/openage for the extraction doc.

fzerorubigd commented on 2016-03-18 10:33

@comgunner you need the original AOE game to extract assets. this assets are not included here.

check the github repo for description : https://github.com/SFTtech/openage

comgunner commented on 2016-03-17 23:49

:(

openage: error: directory does not exist: ./assets

manmatteo commented on 2016-01-22 16:37

I had to install python-numpy and opus-tools to be able to build