Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: onlyoffice-bin 4.2.1-43

Git Clone URL: https://aur-dev.archlinux.org/onlyoffice-bin.git (read-only)
Package Base: onlyoffice-bin
Description: The most complete and feature-rich office and productivity suite
Upstream URL: http://www.onlyoffice.com/
Keywords: office
Licenses: AGPL-3.0
Conflicts: onlyoffice-desktopeditors-portable
Provides: onlyoffice-desktopeditors
Submitter: mikalair
Maintainer: mikalair
Last Packager: mikalair
Votes: 9
Popularity: 5.043017
First Submitted: 2016-11-17 12:33
Last Updated: 2017-01-14 13:13

Latest Comments

thatdude commented on 2017-01-14 12:41

please add this line to package():

chmod +x "${pkgdir}/usr/bin/onlyoffice-desktopeditors"

this script is not executable in the tarball for some reason

sirocco commented on 2016-12-20 04:49

typo: 4.1.2-42 (instead 4.2.1-42)

from namcap output
-----
onlyoffice-bin E: Symlink (opt/onlyoffice/desktopeditors/converter/libcurl.so.4) points to non-existing /usr/lib/libcurl.so.3

onlyoffice-bin E: Dependency alsa-lib detected and not included (libraries ['usr/lib/libasound.so.2'] needed in files ['opt/onlyoffice/desktopeditors/libcef.so'])
onlyoffice-bin E: Dependency nss detected and not included (libraries ['usr/lib/libnssutil3.so', 'usr/lib/libsmime3.so', 'usr/lib/libnss3.so'] needed in files ['opt/onlyoffice/desktopeditors/libcef.so'])
onlyoffice-bin E: Dependency libxtst detected and not included (libraries ['usr/lib/libXtst.so.6'] needed in files ['opt/onlyoffice/desktopeditors/libcef.so'])
onlyoffice-bin E: Dependency qt5-x11extras detected and not included (libraries ['usr/lib/libQt5X11Extras.so.5'] needed in files ['opt/onlyoffice/desktopeditors/DesktopEditors'])
onlyoffice-bin E: Dependency qt5-svg detected and not included (libraries ['usr/lib/libQt5Svg.so.5'] needed in files ['opt/onlyoffice/desktopeditors/imageformats/libqsvg.so'])
onlyoffice-bin E: Dependency gconf detected and not included (libraries ['usr/lib/libgconf-2.so.4'] needed in files ['opt/onlyoffice/desktopeditors/libcef.so'])
-----

VicktorS2 commented on 2016-11-19 00:53

You are making a mistake while editing or even opening a document. This error persists in both Arch and Manjaro.
I tested the universal installer and it worked: http://download.onlyoffice.com/install/desktop/editors/linux/onlyoffice-desktopeditors-installer-x64