Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - nvidia-beta

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: nvidia-beta 378.09-1

Git Clone URL: https://aur-dev.archlinux.org/nvidia-beta.git (read-only)
Package Base: nvidia-beta
Description: NVIDIA driver for Arch's official 'linux' package (beta version)
Upstream URL: http://www.nvidia.com/
Licenses: custom:NVIDIA
Conflicts: nvidia, nvidia-173xx, nvidia-96xx
Provides: nvidia
Submitter: None
Maintainer: Det
Last Packager: Det
Votes: 326
Popularity: 1.138967
First Submitted: 2008-02-10 22:03
Last Updated: 2017-01-19 20:42

Required by (14)

Sources (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Det commented on 2017-01-19 19:34

Omg. How long did I spend because of that misleading comment...

These are *NOT* dependencies. They are, quote, "support for new window systems, ***beyond the existing*** libnvidia-egl-wayland.so.1" (https://devtalk.nvidia.com/default/topic/988593/unix-graphics-announcements-and-news/linux-solaris-and-freebsd-driver-378-09-beta-/).

Goddamn.

blackout24 commented on 2017-01-18 17:05

378.09 is out and libnvidia-egl-wayland.so is no longer part of the driver so the install part will fail, when simply bumping the version number. The EGL Wayland driver and EGL Platform Library is now its own project that has to be packaged from these sources and added as dependency.

- https://github.com/NVIDIA/eglexternalplatform
- https://github.com/NVIDIA/egl-wayland

Det commented on 2016-09-12 19:46

You need to get rid of the first two. Some weird leftovers of probably non-Pacman managed modules.

You can use "pacman -Qo" to check the owners.

kabads commented on 2016-09-12 19:45

[adam@hark ~]$ cat /usr/lib/modules/extramodules-*-ARCH/version
3.18.2-2-ARCH
3.18.2-2-ARCH
4.7.2-1-ARCH

Det commented on 2016-09-11 15:52

The patch is for 4.8 kernels and shouldn't get applied on your 4.7 at all.

How many /usr/lib/modules/extramodules-*-ARCH directories do you have?

$ cat /usr/lib/modules/extramodules-*-ARCH/version

..should produce "4.7", which is lower than the "4.8", and the patch shouldn't apply.

kabads commented on 2016-09-11 15:46

Getting a fail on install. Not sure how to apply the patch.

/home/adam/nvidia-sep/nvidia-beta/src/NVIDIA-Linux-x86_64-370.28-no-compat32/kernel/nvidia-drm/nvidia-drm-drv.c:40:26: fatal error: drm/drm_auth.h: No such file or directory
#include <drm/drm_auth.h>
^
compilation terminated.
make[2]: *** [scripts/Makefile.build:290: /home/adam/nvidia-sep/nvidia-beta/src/NVIDIA-Linux-x86_64-370.28-no-compat32/kernel/nvidia-drm/nvidia-drm-drv.o] Error 1/home/adam/nvidia-sep/nvidia-beta/src/NVIDIA-Linux-x86_64-370.28-no-compat32/kernel/nvidia-drm/nvidia-drm-drv.c:40:26: fatal error: drm/drm_auth.h: No such file or directory
#include <drm/drm_auth.h>
^
compilation terminated.
make[2]: *** [scripts/Makefile.build:290: /home/adam/nvidia-sep/nvidia-beta/src/NVIDIA-Linux-x86_64-370.28-no-compat32/kernel/nvidia-drm/nvidia-drm-drv.o] Error 1
make[1]: *** [Makefile:1457: _module_/home/adam/nvidia-sep/nvidia-beta/src/NVIDIA-Linux-x86_64-370.28-no-compat32/kernel] Error 2
make[1]: Leaving directory '/usr/lib/modules/4.7.2-1-ARCH/build'
make: *** [Makefile:81: modules] Error 2
==> ERROR: A failure occurred in build().
Aborting...

make[1]: *** [Makefile:1457: _module_/home/adam/nvidia-sep/nvidia-beta/src/NVIDIA-Linux-x86_64-370.28-no-compat32/kernel] Error 2
make[1]: Leaving directory '/usr/lib/modules/4.7.2-1-ARCH/build'
make: *** [Makefile:81: modules] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Det commented on 2016-08-25 13:22

Yeah, but there's still extra/nvidia, and you could also test the patch provided.

zobi8225 commented on 2016-08-25 13:21

@det : nop i have clear my cache :-(

Det commented on 2016-08-25 13:04

The talks are in https://devtalk.nvidia.com.

Does this patch work?: https://devtalk.nvidia.com/default/topic/957992/linux/370-23-incompatible-pointer-types-with-nvidia_drm_gem_prime_soft_fence_event-on-32bit-with-4-6-7-/

Svenstaro commented on 2016-08-25 11:41

@Det, can you find a patch for i686 on the current beta?