Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - mpv-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: mpv-git 43403.g5700da4-1

Git Clone URL: https://aur-dev.archlinux.org/mpv-git.git (read-only)
Package Base: mpv-git
Description: Video player based on MPlayer/mplayer2 (git version)
Upstream URL: https://mpv.io
Keywords: media player video
Licenses: GPL
Conflicts: mpv
Provides: mpv
Submitter: rpolzer
Maintainer: qmega
Last Packager: qmega
Votes: 161
Popularity: 1.235312
First Submitted: 2012-12-04 09:21
Last Updated: 2016-06-16 04:15

Required by (57)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

flu commented on 2015-06-28 20:09

Hello, it is failing here:

Resolving deltas: 100% (192724/192724), done.
fatal: did not receive expected object dcfcb052787562504f50cd5404b96283cc6ab8de
fatal: index-pack failed

IncredibleLaser commented on 2015-05-26 16:33

You're completely correct, I mean the OSC. I just searched the internet and the first result I found for the OSC was that it needs luajit, so I just assumed that this is a dependency. I just realized I included your commented dependencies and it so happens that they list lua (but the list is, as you wrote, out of date).

qmega commented on 2015-05-24 05:06

I assume you're talking about the OSC, as the OSD doesn't require lua. Even for that, though, it doesn't have to be luajit. lua52 works as well. Whichever one you use will be picked up as a dependency automatically. What's the rationale for explicitly depending on luajit? It would make trouble for people who use lua52 instead (which I think is most people) and for anyone who wants to build without lua altogether.

IncredibleLaser commented on 2015-05-23 09:46

In order to compile mpv with the OSD, luajit is a needed dependency.

Corubba commented on 2015-03-15 08:55

the waf server seems to be unavailable at the moment, here is a patch to make the bootstrap use a (official) mirror instead. http://pastebin.com/mrKV8HVN

qmega commented on 2015-03-10 01:00

I added it because the official community package did. I checked at the time and I was able to reproduce the issue (no relro or stack canary). However, I can't now, with a current checkout or with the release when the official package added the dep, for some reason. So I don't know what changed, but it looks like hardening-wrapper is no longer needed, so I've removed it. Thanks for pointing it out.

Note that this means PIE will no longer be enabled by default, just because the default makepkg.conf doesn't do that, but it does work if you add the flags.

CounterPillow commented on 2015-03-09 16:49

Is there any specific security reason for hardening-wrapper to be required as a build dependency? It breaks dlang-dmd by hijacking the linker binary name and adding a bunch of unexpected options.

I can remove it after the build process, of course, but I'd rather not have to deal with it at all. Can't the compiler/linker options it adds be added as a patch to the build script?

qmega commented on 2015-02-14 19:39

Sorry, I've been sick and haven't been keeping up with stuff. Made the sed change.

WorMzy commented on 2015-02-12 12:52

It should work again now, rc2 is out, and has been tagged with an underscore instead of a hyphen.

qmega: You might want to modfiy the sed command on the _tagver line to replace hyphens with underscores in case hyphens are used in future versions. Changing it to

sed -e 's:^v::' -e 's:-:_:g'

should work.

shudouken commented on 2015-02-12 12:33

Cannot install/upgrade this because of a hyphen in the pkgver

==> Starting pkgver()...
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: 0.8.0-rc1_330_g545a0e5
:: failed to verify mpv-git integrity