Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: mozart2 2.0.0_alpha.0.4140-5

Git Clone URL: https://aur-dev.archlinux.org/mozart2.git (read-only)
Package Base: mozart2
Description: An open source implementation of Oz 3.
Upstream URL: https://mozart.github.io/
Licenses: BSD
Submitter: beroal
Maintainer: beroal
Last Packager: beroal
Votes: 3
Popularity: 0.000294
First Submitted: 2015-09-25 10:36
Last Updated: 2016-09-17 09:28

Latest Comments

layus commented on 2015-12-14 10:57

I have uploaded a pkgbuild building from git (mozart2-git) that works with the current LLVM/Clang 3.7 and therefore allows to build with the current tcl/tk 8.7.
The compilation takes ~1h of cpu processing, which boils down to 20 minutes on my quad-core i5.

beroal commented on 2015-12-08 18:41

updated

beroal commented on 2015-12-07 14:20

@sytabaresa: Did you try it with tk 8.6?

sytabaresa commented on 2015-12-07 00:08

Hello, a new version is available: http://sourceforge.net/projects/mozart-oz/files/v2.0.0-alpha.0/mozart2-2.0.0-alpha.0%2Bbuild.4140.005f700-x86_64-fc22.rpm/download, it's a rpm, but is easy to change PKGBUILD:

pkgname='mozart2'
pkgver='2.0.0'
pkgrel=1
pkgdesc='An open source implementation of Oz 3.'
arch=('x86_64' 'i386')
url='https://github.com/mozart/mozart2'
license=('BSD')
depends=('tcl>=8.5' 'tk>=8.5' 'emacs')
source=(bin.rpm::http://sourceforge.net/projects/mozart-oz/files/v2.0.0-alpha.0/mozart2-2.0.0-alpha.0%2Bbuild.4140.005f700-x86_64-fc22.rpm/download
https://raw.githubusercontent.com/mozart/mozart2/master/LICENSE.txt
)
sha512sums=('dbdf8619d41918e7403a8ea3a7759fdc15013c9bece37ce10d16371428f15c66a31be3624175a4d49ce318647200eac56806922ba240935e421e061e32d8690c'
'c21dfa28faa03a703d853416126d2135330919036b33b40c790569bccb9a0fdbb3cd3acde0cd001a84333f7fe25a18d02be970612720d7726b01a26f0317a78b')
package() {
cd "${srcdir}"
install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
cp -R ./usr/* "$pkgdir/usr"
}

I think is not necessary to include tk<8.6 and tcl<8.6 more.