Package Details: mongochef 4.4.2-1

Git Clone URL: https://aur-dev.archlinux.org/mongochef.git (read-only)
Package Base: mongochef
Description: A free universal database tool for developers and database administrators
Upstream URL: http://3t.io/mongochef/
Keywords: MongoDB
Licenses: custom
Provides: mongochef
Submitter: random-access
Maintainer: random-access
Last Packager: random-access
Votes: 15
Popularity: 1.231155
First Submitted: 2015-09-18 00:26
Last Updated: 2016-11-27 12:56

Latest Comments

s0nspark commented on 2016-09-28 15:11

Awesome - glad to help :)

random-access commented on 2016-09-22 12:18

Thanks, s0nspark, didn't know that.
Just updated the build, including your patch.

s0nspark commented on 2016-09-22 11:55

This addresses the checksum issue... the downloads need to be versioned ;-)

--- PKGBUILD.orig 2016-09-22 07:56:24.106288395 -0400
+++ PKGBUILD 2016-09-22 07:54:27.292952523 -0400
@@ -12,8 +12,8 @@
provides=('mongochef')

source=("mongochef.desktop" "mongochef")
-source_i686=("https://cdn.3t.io/mongochef-core/linux/${pkgver}/mongochef-linux-x86-dist.tar.gz")
-source_x86_64=("https://cdn.3t.io/mongochef-core/linux/${pkgver}/mongochef-linux-x64-dist.tar.gz")
+source_i686=("$pkgname-$pkgver-x86.tar.gz::https://cdn.3t.io/mongochef-core/linux/${pkgver}/mongochef-linux-x86-dist.tar.gz")
+source_x86_64=("$pkgname-$pkgver-x64.tar.gz::https://cdn.3t.io/mongochef-core/linux/${pkgver}/mongochef-linux-x64-dist.tar.gz")

sha256sums=('a603fd54a34f8aa59a70580fd4321db24f439ceb746545f1cf6c0216f7f8169e'
'3b03d036ccfa0e25b3f797a8f9fd6076b7b6dd131ab04879cb92d5aa130b8df1')

random-access commented on 2016-09-22 10:23

Varakh, I just checked all checksums manually, they should match. A test installation with the current build worked as well, I just installed it on x64 but I double-checked the x86 checksum.

Could you please tell me on which file the checksum test fails, the command you used for installing this package and your cpu architecture (x64/x86) or post the relevant log output? I'll try to reproduce the error on my machine.

EDIT: Just saw that there's a new version of mongochef out & updated the build to v4.3.0.

Varakh commented on 2016-09-22 09:43

Checksums do not match.

random-access commented on 2016-08-30 23:50

This is a server issue. Error message from the main website (http://3t.io/mongochef/):This website is being moved to another server at the moment. Please try again later.
Can't do anything about that.
I'll update the package if there's a new link to the sources.

nexcode commented on 2016-08-30 22:50

get https://cdn.3t.io/mongochef-core/linux/4.1.1/mongochef-linux-x64-dist.tar.gz
---
ERROR
The request could not be satisfied.

random-access commented on 2016-08-28 21:42

Integrity check should work with the new build I just checked in. Sorry for not fixing that issue ASAP.

swordbeta commented on 2016-06-16 08:04

Integrity can not be verified:

==> Validating source_x86_64 files with sha256sums...
mongochef-linux-x64-dist.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!

random-access commented on 2016-02-17 00:57

programacho, I didn't change the java version in the startup script because this might mess up some user's default java setup. Instead, I added some code to automatically start mongochef with a java version >= 8, if this is not set as default. Such a java version must exist on the system after installation of mongochef because it is declared in the dependencies.

programacho commented on 2016-02-15 11:38

Don't forget to change JRE version to 8:

sudo archlinux-java set java-8-openjdk/jre

random-access commented on 2015-12-11 13:35

phw, you're totally right, thanks for your feedback!
Updated dependencies, now requires java-runtime>=8.

phw commented on 2015-12-11 10:03

The dependencies should be updated, mongochef requires at least java-runtime>=8

Otherwise it will fail with
Exception in thread "main" java.lang.UnsupportedClassVersionError: t3/dataman/mongodb/app/MongoChefApp : Unsupported major.minor version 52.0

random-access commented on 2015-11-12 18:38

Thanks for the hint! I've just added a startup script in /usr/bin/mongochef, containing the java -jar command, and upgraded the package to the latest MongoChef version.

tjaart commented on 2015-11-12 14:24

For me it would be useful to have the startup script in /usr/bin/mongochef