Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - mongochef

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: mongochef 4.4.2-1

Git Clone URL: https://aur-dev.archlinux.org/mongochef.git (read-only)
Package Base: mongochef
Description: A free universal database tool for developers and database administrators
Upstream URL: http://3t.io/mongochef/
Keywords: MongoDB
Licenses: custom
Provides: mongochef
Submitter: random-access
Maintainer: random-access
Last Packager: random-access
Votes: 15
Popularity: 1.231155
First Submitted: 2015-09-18 00:26
Last Updated: 2016-11-27 12:56

Latest Comments

« First ‹ Previous 1 2

programacho commented on 2016-02-15 11:38

Don't forget to change JRE version to 8:

sudo archlinux-java set java-8-openjdk/jre

random-access commented on 2015-12-11 13:35

phw, you're totally right, thanks for your feedback!
Updated dependencies, now requires java-runtime>=8.

phw commented on 2015-12-11 10:03

The dependencies should be updated, mongochef requires at least java-runtime>=8

Otherwise it will fail with
Exception in thread "main" java.lang.UnsupportedClassVersionError: t3/dataman/mongodb/app/MongoChefApp : Unsupported major.minor version 52.0

random-access commented on 2015-11-12 18:38

Thanks for the hint! I've just added a startup script in /usr/bin/mongochef, containing the java -jar command, and upgraded the package to the latest MongoChef version.

tjaart commented on 2015-11-12 14:24

For me it would be useful to have the startup script in /usr/bin/mongochef