Notice: Undefined variable: name in /srv/http/vhosts/ on line 248

Package Details: mnemosyne 2.4.1-3

Git Clone URL: (read-only)
Package Base: mnemosyne
Description: A flash-card tool with a sophisticated card review algorithm
Upstream URL:
Keywords: Anki flashcard learn memorize
Licenses: GPL
Conflicts: mnemosyne-bzr
Submitter: wide-eyed
Maintainer: smls
Last Packager: smls
Votes: 75
Popularity: 1.143298
First Submitted: 2007-11-04 20:08
Last Updated: 2017-02-02 16:02

Latest Comments

1 2 3 4 5 Next › Last »

bonob commented on 2017-01-11 15:16

Support for Fcitx input method requires fcitx-qt5 when upgrading to Mnemosyne 2.4.
Not sure if that deserves an optional dependency here, or maybe a note on the wiki page?
In any case, if someone runs into the same problem as me, my comment may be of help.

smls commented on 2016-12-21 00:47

@bialou: Added.

bialou commented on 2016-12-20 23:32

@smls So we probably should put that python-pillow package as a dependency.
.... or any other package that has pillow and/or(?) image in it.
P.S. I run i3wm, if it matters.

bialou commented on 2016-12-20 23:26

@Ichimonji10 "pip3 install --user image" installed 3 packages: django-1.10.4 image-1.5.5 pillow-3.4.2;

I uninstalled them manually and tried python-pillow package instead. Everything still works good now and I don't have that error on "Browse Cards" button you have. So, it must be something else going on. The only thing I did before installing python-pillow is to uninstall django, image, and pillow with "pip uninstall ..."

Ichimonji10 commented on 2016-12-20 22:57

@smls, thanks for the fix! Mnemosyne no longer suffers from the error I outlined.

I now suffer from the same error described by @bialou: PIL (python imaging library) is not installed. The suggested solution is to install image with pip. I *think* a more generic solution is to install the python-pillow package with pacman. It works well enough to let mnemosyne start.

Edit: I'm now suffering from a new issue. It's probably an issue with mnemosyne itself. @smls, can you take a look, and let the maintainers know about it if appropriate? This error log pops up when I press the "Browse cards" button.

bialou commented on 2016-12-20 06:16

@hongleong: Installing it manually "pip3 install --user image" takes care of that problem. Hopefully, this can be fixed correctly later. Thank you, for help.

hongleong commented on 2016-12-20 03:28

@bialou: pip3 install --user image

bialou commented on 2016-12-20 03:03

mnemosyne 2.4-2 fails to start. /usr/bin/python ==> Python 3.5.2

~]$ mnemosyne
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
QIODevice::write (QProcess): device not open
An unexpected error has occurred.
Please forward the following info to the developers:

Traceback (innermost last):
File "/usr/bin/mnemosyne", line 229, in <module>
File "/usr/lib/python3.5/site-packages/mnemosyne/libmnemosyne/", line 234, in initialise
File "/usr/lib/python3.5/site-packages/mnemosyne/pyqt_ui/", line 52, in activate
File "/usr/lib/python3.5/site-packages/mnemosyne/libmnemosyne/", line 121, in start_review
File "/usr/lib/python3.5/site-packages/mnemosyne/libmnemosyne/review_controllers/", line 62, in reset
File "/usr/lib/python3.5/site-packages/mnemosyne/libmnemosyne/review_controllers/", line 123, in show_new_question
File "/usr/lib/python3.5/site-packages/mnemosyne/libmnemosyne/review_controllers/", line 200, in update_dialog
File "/usr/lib/python3.5/site-packages/mnemosyne/libmnemosyne/review_controllers/", line 237, in update_qa_area
File "/usr/lib/python3.5/site-packages/mnemosyne/pyqt_ui/", line 248, in clear_answer
File "/usr/lib/python3.5/site-packages/mnemosyne/pyqt_ui/", line 145, in update_stretch_factors
File "/usr/lib/python3.5/site-packages/mnemosyne/pyqt_ui/", line 114, in estimate_height
from PIL import Image
ImportError: No module named 'PIL'

smls commented on 2016-12-16 12:21

It turns out `qt5-webengine` needed to be explicitly specified as a dependency.
The package has been updated.
(I thought `python-pyqt5` pulls in all the Qt stuff, but apparently Qt is more modular now than it was during Qt4 times.)

smls commented on 2016-12-16 11:57

It starts fine for me. Maybe I forgot to explicitly specify a dependency or something?
Please ensure that your Arch Linux is fully upgraded, and that /usr/bin/python points to python3.
Meanwhile, I'll try to investigate the issue on my end.