Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - masterpdfeditor

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: masterpdfeditor 4.0.30-1

Git Clone URL: https://aur-dev.archlinux.org/masterpdfeditor.git (read-only)
Package Base: masterpdfeditor
Description: A complete solution for creation and editing PDF files
Upstream URL: http://code-industry.net/free-pdf-editor.php
Keywords: master-pdf-editor
Licenses: custom
Submitter: farseerfc
Maintainer: Scimmia
Last Packager: Scimmia
Votes: 14
Popularity: 7.965336
First Submitted: 2016-12-05 01:50
Last Updated: 2017-01-25 07:03

Latest Comments

1 2 Next › Last »

ranger commented on 2017-01-25 17:00

But it won't update from a repo and that's not covered.
Anyway, your package, you don't have to do it properly if you don't want to. That's the meaning of aur ;)

Scimmia commented on 2017-01-25 16:58

And masterpdfeditor-qt5 has always conflicted with this, so that's covered.

ranger commented on 2017-01-25 16:40

In the aur not, but it helps if you use a local or online repo.
But even without a repo, if you try to install masterpdfeditor together with masterpdfeditor-qt5 you will have an error. 'replaces' or 'conflicts' is a way to tell pacman that two packages can't be install together.

https://wiki.archlinux.org/index.php/PKGBUILD#replaces

Scimmia commented on 2017-01-25 16:34

replaces doesn't do anything in the AUR

ranger commented on 2017-01-25 15:33

If this is the new Qt5 version, shouldn't you include a
replaces=('masterpdfeditor-qt5')
line in the PKGBUILD?

Scimmia commented on 2017-01-25 07:06

This is now the Qt5 version. If you need the Qt4 version, it's available under masterpdfeditor-qt4.

FadeMind commented on 2017-01-17 12:05

4.0.30 PKGBUILD: https://github.com/FadeMind/mnjpkgbuilds/tree/master/masterpdfeditor-qt5

RushAur commented on 2017-01-15 13:01

Edit: v4.0.30
@FadeMind: I think no need to add one more dependency (The less, the better..), if install does the job, or am I missing something...

PKGBUILD: Read the comments in the file. You can download it with:
curl -O https://gist.githubusercontent.com/0devnull0/7f60a440a59688a4dbdcfac2683aa279/raw/dea347c967cd26a81769e7be95f169508ca77b0b/PKGBUILD

shen commented on 2017-01-15 06:51

Hey there

Please update.
The software is prompting that a new version is available.
Thnx.

bmafy commented on 2017-01-08 07:37

RushAur, have you been able to update the pkg? Can u share your PKGBUILD?
Thanks for your help!