Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - maniadrive

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: maniadrive 1.2-19

Git Clone URL: https://aur-dev.archlinux.org/maniadrive.git (read-only)
Package Base: maniadrive
Description: Acrobatic racing game
Upstream URL: http://maniadrive.raydium.org/
Licenses: GPL, custom:CC by-sa 2.0
Submitter: None
Maintainer: Jeanbon
Last Packager: xyproto
Votes: 84
Popularity: 0.124023
First Submitted: 2006-05-25 04:26
Last Updated: 2015-10-24 10:57

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

kfgz commented on 2010-11-25 14:13

You should change 'makedeps' to 'makedepends'.

Anonymous comment on 2010-11-07 23:19

I made some corrections in the PKGBUILD. Builds and installs properly. http://aur.pastebin.com/zbnbkFNu

Anonymous comment on 2010-11-07 23:16

I made some corrections in the PKGBUILD. Builds and installs properly. http://aur.pastebin.com/zbnbkFNu

xyproto commented on 2010-11-05 13:47

Ok, thanks for the research. The package was updated at the time of my previous comment.

kfgz commented on 2010-11-05 11:02

I think that namcap is wrong. As you can see all libraries are in place including /usr/lib32/libGL.so.1 (lib32-libgl)

ldd /opt/maniadrive/mania2.static
linux-gate.so.1 => (0xf7798000)


libGL.so.1 => /usr/lib32/libGL.so.1 (0xf7719000)


libGLU.so.1 => /usr/lib32/libGLU.so.1 (0xf76ae000)
libasound.so.2 => /usr/lib32/libasound.so.2 (0xf75e9000)
libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf75cf000)
libc.so.6 => /usr/lib32/libc.so.6 (0xf7482000)
libXext.so.6 => /usr/lib32/libXext.so.6 (0xf7474000)
libX11.so.6 => /usr/lib32/libX11.so.6 (0xf735a000)
libdl.so.2 => /usr/lib32/libdl.so.2 (0xf7356000)
libm.so.6 => /usr/lib32/libm.so.6 (0xf7331000)
libXxf86vm.so.1 => /usr/lib32/libXxf86vm.so.1 (0xf732c000)
libXdamage.so.1 => /usr/lib32/libXdamage.so.1 (0xf7328000)
libXfixes.so.3 => /usr/lib32/libXfixes.so.3 (0xf7323000)
libX11-xcb.so.1 => /usr/lib32/libX11-xcb.so.1 (0xf7321000)
libxcb-glx.so.0 => /usr/lib32/libxcb-glx.so.0 (0xf7310000)
libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf72f8000)
libdrm.so.2 => /usr/lib32/libdrm.so.2 (0xf72ee000)
libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7200000)
libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf71e6000)
librt.so.1 => /usr/lib32/librt.so.1 (0xf71dd000)
/lib/ld-linux.so.2 (0xf7799000)
libXau.so.6 => /usr/lib32/libXau.so.6 (0xf71da000)
libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf71d4000)

xyproto commented on 2010-11-05 10:11

kfgz, if I remove lib32-nvidia-utils and use lib32-libgl instead, namcap gives the following error:
maniadrive E: Dependency detected and not included (lib32-nvidia-utils) from files ['opt/maniadrive/mania2.static', 'opt/maniadrive/mania_server.static', 'opt/maniadrive/mania_drive.static']
maniadrive W: Dependency included and not needed ('lib32-libgl')
Nevertheless, I made the change you suggested.

If someone could test if it works without lib32-nvidia-utils installed, it would be appreciated.
Thanks.

kfgz commented on 2010-11-04 17:11

Please remove lib32-nvidia-utils from depends array and put lib32-libgl instead.

kfgz commented on 2010-11-04 16:43

Please remove lib32-nvidia-utils from depends array.

xyproto commented on 2010-11-04 12:41

Adopted the package and made it installable for x86_64 too.

Svenstaro, I don't know if it's dead or not, but it's still a fun game. :)

Svenstaro commented on 2010-11-03 11:58

Is this dead upstream?