Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: lyx-git 2.2.0.r1430.g6c13af3f29-1

Git Clone URL: https://aur-dev.archlinux.org/lyx-git.git (read-only)
Package Base: lyx-git
Description: An advanced WYSIWYM document processor & LaTeX front-end
Upstream URL: http://www.lyx.org
Keywords: latex lyx lyx-git texlive
Licenses: GPL
Conflicts: lyx lyx-git
Provides: lyx-git
Replaces: lyx lyx-git
Submitter: a36233
Maintainer: a36233
Last Packager: a36233
Votes: 2
Popularity: 0.029615
First Submitted: 2016-07-06 09:25
Last Updated: 2017-02-01 19:26

Latest Comments

a36233 commented on 2016-09-27 09:56

Last commit I've added bc to makedepends

bugaboo commented on 2016-09-27 01:32

lyx-git should have bc as dependency, I think. It fails to compile without it giving following errors:

frontends/qt4/liblyxqt4.a(FancyLineEdit.o): In function
`lyx::frontend::IconButton::IconButton(QWidget*)':
FancyLineEdit.cpp:(.text+0x735): undefined reference to `vtable for
lyx::frontend::IconButton'

Here's the link I found looking for the fix:
http://marc.info/?l=lyx-devel&m=131938086013112&w=2

a36233 commented on 2016-07-06 10:46

texlive-core and texlive-latexextra where made optional, this way makes possible to have texlive Manual instalation and lyx.