Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - llpp-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: llpp-git 22.r71.g2bf99be-1

Git Clone URL: https://aur-dev.archlinux.org/llpp-git.git (read-only)
Package Base: llpp-git
Description: Fast, featureful PDF viewer based on MuPDF.
Upstream URL: http://repo.or.cz/w/llpp.git
Licenses: custom
Conflicts: llpp
Provides: llpp
Submitter: mfwitten
Maintainer: None
Last Packager: drrossum
Votes: 61
Popularity: 0.000073
First Submitted: 2010-10-26 22:21
Last Updated: 2016-01-11 17:25

Dependencies (23)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

flu commented on 2014-08-17 17:25

llppac is not found. I found it in a another location:

install misc/llppac "$pkgdir"/usr/bin/llppac
^^^^^

stevenhoneyman commented on 2014-08-17 16:06

Please change the local clone to "llpp" instead of "repo" - comment below from 10 months ago asking the same.
Thanks.

mfwitten commented on 2013-12-26 10:55

How's that?

alxarch commented on 2013-12-25 09:52

Latest build on fresh installation requires glu also

darkxsun commented on 2013-10-16 15:26

This PKGBUILD is storing the local git clone in 'repo/', which conflicts with (e.g.) the repo package. It should probably store in (something like) 'llpp/' instead.

menta commented on 2013-08-13 13:58

Thank you for including llppac in the package. You may also include a .desktop file, see a draft here: http://pastebin.com/ceCVuni7. The list of supported MIME types was generated with the following script: http://pastebin.com/hi6LPW6y.

By investigating the llppac script and running it on sample files I discovered additional optional dependencies:
'antiword: conversion of Microsoft Word (.doc) documents (option 2)'
'zip: handling of png and jpeg images'
'texlive-core: dvi conversion'

A minor comment: Members of the "base" and "base-devel" groups should not be included in makedepends array (https://wiki.archlinux.org/index.php/PKGBUILD#makedepends). I think members of the "base" group are also meaningless in the optdepends array. To check those:
pacman -Qi file gzip bzip2 bash make gcc | grep -E "Name|Groups"

menta commented on 2013-07-23 09:42

Please package the llppac script as well. You may use the following lines for optdepends:
'xsel: Text selection'
'unoconv: conversion of office documents'
'imagemagick: image conversion'
'librsvg: svg conversion (option #1)'
'inkscape: svg conversion (option #2)'
'princexml: html conversion'
'ghostscript: ps, dvi and djvu conversion'
'djvulibre: djvu conversion'

More info: https://sympa.inria.fr/sympa/arc/caml-list/2013-07/msg00043.html

Thank you in advance!

mfwitten commented on 2013-05-20 08:58

For some reason, I was no longer receiving notifications about comments. The PKGBUILD has now been updated as suggested.

Earnest commented on 2013-04-30 21:29

Updated PKGBUILD for pacman 4.1 ==> http://ix.io/5pY/sh

Earnest commented on 2013-04-30 20:48

Updated and standard PKGBUILD: http://ix.io/5pX/sh