Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - linux-tresor

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: linux-tresor 3.18.19-1

Git Clone URL: https://aur-dev.archlinux.org/linux-tresor.git (read-only)
Package Base: linux-tresor
Description: The Linux-tresor kernel and modules with integrated TRESOR
Upstream URL: http://www1.informatik.uni-erlangen.de/tresor
Licenses: GPL2
Conflicts: kernel26-tresor
Provides: kernel26-tresor=3.18.19
Replaces: kernel26-tresor
Submitter: ido
Maintainer: clfarron4
Last Packager: clfarron4
Votes: 3
Popularity: 0.002359
First Submitted: 2013-09-29 22:50
Last Updated: 2015-07-22 14:03

Latest Comments

1 2 Next › Last »

clfarron4 commented on 2015-06-18 16:17

Unflagged: There is a lag between when the Git and the snapshots you download are updated and when the information on the AUR4 page is updated to reflect this.

The Snapshot Version is 3.18.16

clfarron4 commented on 2015-03-16 14:33

I have received correspondence which indicates that there may be issues between ext4 superblocks and TRESOR when using ext4 on a TRESOR encrypted partition.

[b]I would like to emphasise that TRESOR should be treated as experimental software, thus isn't production ready and shouldn't be used for personal storage. If you have any worries, you should back-up your data and move to non-TRESOR encrypted partitions.[/b]

If you would like to help diagnose the issue, please see [url=https://bbs.archlinux.org/viewtopic.php?pid=1511640#p1511640]this post[/url].

If you have been affected by the issue and are looking to recover the data on the partition, please see [url=https://bbs.archlinux.org/viewtopic.php?pid=1511638#p1511638]this post[/url].

clfarron4 commented on 2015-01-12 10:02

3.18.2-2: Updated PKGBUILD for pacman 4.2. No new changes from 3.18.2-1

clfarron4 commented on 2014-12-23 19:24

Coming soon:
linux-tresor version 3.18.1-1

I have to give credit to my package tester (and computing "partner-in-crime") Andes Ho and the valuable contributions from Seth Dickson (both are given credit in the PKGBUILDs), as the three of us have put pre-init keyboard support back into the package AND successfully bumped the package up to 3.17.7-1 and 3.18+.

They have my greatest thanks :)

NOTE: Pre-built packages will uploaded to my repository after the New Year, when Andes and I have enough bandwidth to do so.

clfarron4 commented on 2014-12-21 21:22

3.15.10-3-lts-tresor - Reverted changes to KEYBOARD_ATKBD, MOUSE_SERIAL and SERIO options made by the Arch Developers in this svn commit to the kernel [1].

Result: Keyboard input when asked for pass-phrase now works.

[1] https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=a1bf3bc4dde855b65095714189f5dccf562b0d9f

Also, previous comment still applies. I have no idea why it doesn't build with 3.16+, but there is the linux-lts-tresor package, which will be going for a while.

clfarron4 commented on 2014-12-21 21:21

3.15.10-3-lts-tresor - Reverted changes to KEYBOARD_ATKBD, MOUSE_SERIAL and SERIO options made by the Arch Developers in this svn commit to the kernel [1].

Result: Keyboard input when asked for pass-phrase now works.

[1] https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=a1bf3bc4dde855b65095714189f5dccf562b0d9f

Also, previous comment still applies. I have no idea why it doesn't build with 3.16+.

clfarron4 commented on 2014-09-03 16:53

@yax: Hi, it's the maintainer here. I'm currently lost as to why it doesn't build with the 3.16 kernel. I'm also working on it.

yax commented on 2014-09-03 06:10

Very good!
The only one source of updated linux-tresor, bravo ARCHlinux team!
I hope you will update it!
Thanks!!!

clfarron4 commented on 2014-08-17 19:50

@Det: Can you actually build this with the 3.16 branch? I get stuck at the following:

LD init/built-in.o
kernel/built-in.o: In function `pm_suspend':
(.text+0x53baa): undefined reference to `tresor_thaw_processes'
Makefile:887: recipe for target 'vmlinux' failed
make: *** [vmlinux] Error 1
==> ERROR: A failure occurred in build().
Aborting...

ido commented on 2013-11-18 10:57

Simple update instructions for newer 3.11.x/3.12 kernels:

1. Edit patch-for-tresor-patch-3.8.2_aesni.patch to change 11 and 3 in:
+ PATCHLEVEL = 11
+ SUBLEVEL = 3
...to your desired patchlevel and sublevel (e.g. 3.11.6 is 11 and 6).
2. Edit pkgver variable in PKGBUILD (e.g. pkgver=3.11.6)
3. makepkg -s

As with all of my other packages:
NOTE: To request changes to this package, please submit a pull request
to the GitHub repository at https://github.com/ido/packages-archlinux
Otherwise, open a GitHub issue. Thank you! -Ido