Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - linux-libre-pae

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: linux-libre-pae 4.9.5_gnu-1

Git Clone URL: https://aur-dev.archlinux.org/linux-libre-pae.git (read-only)
Package Base: linux-libre-pae
Description: The Linux-libre-pae kernel and modules with PAE support (HIGHMEM64G)
Upstream URL: https://linux-libre.fsfla.org/
Licenses: GPL2
Provides: linux-pae=4.9.5
Submitter: Emulatorman
Maintainer: Emulatorman
Last Packager: Emulatorman
Votes: 1
Popularity: 0.000001
First Submitted: 2014-11-24 22:25
Last Updated: 2017-01-22 23:13

Dependencies (11)

Required by (4)

Sources (17)

Latest Comments

1 2 Next › Last »

TiborB commented on 2015-03-31 21:58

I understand all, it is just pitty ... :)

Emulatorman commented on 2015-03-31 21:12

ath9k-htc-firmware refuses to install when linux-firmware is installed because that package contains ath9k-htc files inside it too.
We blacklisted linux-firmware on Parabola not only because it contains blobs, but it contains another files weren't built from source due which Arch guys frequently don't meet Parabola's policies with regard to building the package from source.
Otherwise i don't like uninstall and then install back packages too like you, but in this case, it isn't my fault since Arch toolchains supports i686 and x86-64 only :S

TiborB commented on 2015-03-31 17:37

it is complicated - I downloaded ath9k-htc-firmware-1.3.2-10-any.pkg.tar.xz - this is fine, but it refused to install because of conflict with linux-firmware that is in turn required by linux-pae and linux.
Generally I dont like workarounds like temporarily uninstall and then install back...

I will think about it :)

Emulatorman commented on 2015-03-31 01:28

If you have ath9k-htc-firmware built and installed in your machine, you don't need have xtensa-unknown-elf-binutils and xtensa-unknown-elf-gcc installed in your system because those packages are added to makedepends, not depends[0]. You should install binutils and gcc again after ath9k-htc-firmware building.

[0]:https://projects.parabola.nu/abslibre.git/tree/libre/ath9k-htc-firmware/PKGBUILD#n11

TiborB commented on 2015-03-30 17:22

But at the end I must have them installed to install linux-libre-pae...

Emulatorman commented on 2015-03-30 04:48

Those packages are useful for ath9k-htc-firmware (or similar package) building only, not to use for the system.

Emulatorman commented on 2015-03-30 04:41

xtensa-unknown-elf-binutils and xtensa-unknown-elf-gcc are toolchains for cross-compiling to build the firmware files for the Qualcomm Atheros AR7010 and AR9271 that contains Tensilica core (xtensa) architecture.

TiborB commented on 2015-03-29 17:39

To be more specific - the problem is one of dependencies: xtensa-unknown-elf-binutils package that conflicts with binutils backage. And I am afraid to replace standard binutils package with something I am not sure what exactly it is and if it is full-fledged replacement of the distro package

Emulatorman commented on 2015-03-29 00:23

Also, if linux-libre-firmware dependencies are very complicated and problematic you can download those packages from our distro too [0][1]

[0]:https://www.parabola.nu/packages/libre/any/ath9k-htc-firmware/
[1]:https://www.parabola.nu/packages/libre/any/openfwwf/

Emulatorman commented on 2015-03-29 00:23

Also, if linux-libre-firmware dependencies are very complicated and problematic you can download those packages from our distro too [0]

[0]:https://www.parabola.nu/packages/libre/any/ath9k-htc-firmware/
[1]:https://www.parabola.nu/packages/libre/any/openfwwf/