Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - libdrm2-amdgpu-pro

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: libdrm2-amdgpu-pro 16.30.3.315407-2

Git Clone URL: https://aur-dev.archlinux.org/amdgpu-pro-installer.git (read-only)
Package Base: amdgpu-pro-installer
Description: Userspace interface to kernel DRM services -- runtime
Upstream URL: http://www.amd.com
Licenses: custom:AMD
Submitter: LEW21
Maintainer: Corngood
Last Packager: Corngood
Votes: 46
Popularity: 8.268778
First Submitted: 2016-03-28 22:44
Last Updated: 2016-08-29 16:36

Pinned Comments

Corngood commented on 2016-07-02 18:27

This is a generated PKGBUILD. The full source is available at:

https://github.com/corngood/archlinux-amdgpu

Feel free to post issues and send PRs.

Discussion of 16.60 update is here: https://github.com/corngood/archlinux-amdgpu/pull/28

Latest Comments

1 2 3 4 5 6 ... Next › Last »

hakzsam commented on 2017-01-25 11:37

Hi,

Any chances you can update the package to 16.40? Because this one is pretty old and it seems to require linux 4.7.

Thanks.

xier commented on 2017-01-24 14:50

http://xier.dyn.ch now has http://pastebin.com/Pfsirxtb prebuilt in case someone wants to try 16.50. No guarantee it works for others though (personal backup repo).

Corngood commented on 2017-01-09 14:22

@pew yeah, github would be best

darkbasic commented on 2017-01-09 11:34

What about filing a bug report on github?

pew commented on 2017-01-09 06:56

Hi, is there any place like and irc channel or active forum thread for discussing this package? I have some questions but I don't want to fill up the comments with stuff that isn't relevant to most people. If nothing already exists, I'm chilling on #amdgpu-pro on oftc.

darkbasic commented on 2017-01-02 15:05

Yes, downgrade xorg to 1.18

Renfield commented on 2017-01-02 13:52

Thanks DarkBasic. I'm always missing things, and I missed nmset's comment further below that contains the PKGBUILD. I managed to build a 16.50 package using that, but then when I boot into it, the Xorg log mentions incompatible ABIs. I suspect, looking at your comment in the Phoronix benchmark post, that my problem here is that I'm running Xorg 1.19.

Corngood commented on 2017-01-02 01:56

IMO the most promising path forward is this PR:

https://github.com/corngood/archlinux-amdgpu/pull/23

If someone can take that, update it for 16.50 using the patches I made for NixOS, and test it, I'll merge it and update AUR.

16.40 -> 16.50 didn't take much work on NixOS, so it shouldn't be a big job.

If anyone's interested in doing this, we can coordinate on github and I'll help as much as possible.

Cheers

darkbasic commented on 2017-01-02 00:56

To use my patches you will have to know what you're doing first... You can start by having a look at this post: https://www.phoronix.com/forums/forum/linux-graphics-x-org-drivers/open-source-amd-linux/920973-fresh-arch-linux-benchmarks-of-amdgpu-amdgpu-pro?p=921112#post921112

Renfield commented on 2017-01-01 23:33

Is anyone supporting this? I tried adding the patch files darkbasic linked to into the package directory that I'm building this from, but it still tries to download 16.30. How do I get it to download and use 16.50?