Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - libcouchbase-2.4

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: libcouchbase-2.4 2.4.9-2

Git Clone URL: https://aur-dev.archlinux.org/libcouchbase-2.4.git (read-only)
Package Base: libcouchbase-2.4
Description: The C library provides fast access to documents in Couchbase Server 2.4.x
Upstream URL: https://github.com/couchbase/libcouchbase
Licenses: Apache
Conflicts: libcouchbase
Submitter: kiz
Maintainer: therisen06
Last Packager: therisen06
Votes: 0
Popularity: 0.000000
First Submitted: 2014-11-27 10:23
Last Updated: 2015-07-19 11:15

Latest Comments

therisen06 commented on 2015-05-14 08:28

I think I solved the 'cbc' name clash problem for now.

Yesterday libcouchbase 2.5 has been released. Since this package contains the version 2.4 in the package name, I've asked to take over the original libcouchbase package to use it for distributing version 2.5.

PiroXiline commented on 2015-05-13 12:59

Modified PKGBUILD to build 2.4.9: http://pastebin.com/nN3KnjVd
There is file conflict happen:
# pacman -U libcouchbase-2.4-2.4.9-1-x86_64.pkg.tar.xz
...
(1/1) checking for file conflicts
error: failed to commit transaction (conflicting files)
libcouchbase-2.4: /usr/bin/cbc exists in filesystem
Errors occurred, no packages were upgraded.

$ pkgfile /usr/bin/cbc
community/coin-or-cbc

Hyphen & libreoffice-fresh depends on coin-or-cbc package.
I've removed libreoffice-fresh for now. Ha-ha.

This going to be common problem for users & devs who will use this package. Do you know how we can solve this?

kiz commented on 2015-01-09 08:17

@therisen06 I'm no longer use this, you may want to adopt this package

therisen06 commented on 2015-01-09 08:16

The current version does not build properly and is outdated. Please find below an updated PKGBUILD:

http://pastebin.com/HVTWDnU0