Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - kst-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: kst-git 2.0.8-1

Git Clone URL: https://aur-dev.archlinux.org/kst-git.git (read-only)
Package Base: kst-git
Description: Fast real-time large-dataset viewing and plotting tool for KDE
Upstream URL: http://kst-plot.kde.org
Licenses: GPL
Conflicts: kst
Submitter: Malkut
Maintainer: Malkut
Last Packager: Malkut
Votes: 3
Popularity: 0.259209
First Submitted: 2015-07-25 23:06
Last Updated: 2016-02-07 19:17

Dependencies (10)

Required by (0)

Sources (2)

Latest Comments

Malkut commented on 2016-02-08 16:49

Added qt5-svg dependency

Kefused commented on 2016-02-07 17:22

I had to install qt5-svg to successfully build.

Malkut commented on 2016-02-04 21:51

I have fixed the issue with pkgver variable.

Kst maintainer have recently started to use svgz instead of svg which broke the install (cmake was trying to copy svg files that didn't exist!) I fixed that too.

Tell me if it builds on your system know.

DCengineer commented on 2016-02-04 05:43

It is giving me the following error:

~~~
/tmp/pkgbuild-1000/kst-git/PKGBUILD: line 21: 2.0.8-084d3ad: command not found
==> ERROR: pkgver is not allowed to be empty.
==> ERROR: pkgver() generated an invalid version:

==> ERROR: the build failed
-> Status failed (1): kst-git
~~~

f0rdprefect commented on 2015-09-29 21:18

builds like a charm, installs and runs. Tomorrow I will throw some data at kst. Great that there is an AUR for this amazing tool.

Malkut commented on 2015-09-28 14:12

@f0rdprefect I fixed the problem (at least on my side!) tell if you have any other problems

f0rdprefect commented on 2015-09-28 07:03

netcdf-cxx-legacy seems no longer to be available in (aur). Thus kst-git does not build