Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - kokua-secondlife

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: kokua-secondlife 4.1.2.40000-1

Git Clone URL: https://aur-dev.archlinux.org/kokua-secondlife.git (read-only)
Package Base: kokua-secondlife
Description: An Open Source third party viewer for Second Life® (secondlife), only.
Upstream URL: http://www.kokuaviewer.org
Keywords: games Life Open opensim Second secondlife Simulator
Licenses: GPL
Conflicts: kokua-opensim
Submitter: GordonGR
Maintainer: GordonGR (dwheeler)
Last Packager: GordonGR
Votes: 9
Popularity: 0.000114
First Submitted: 2014-09-07 15:19
Last Updated: 2016-11-28 14:35

Required by (0)

Sources (6)

Latest Comments

1 2 3 4 5 6 Next › Last »

GordonGR commented on 2015-11-02 09:10

Dwheeler, you are now co-maintainer. Thank you :-)

dwheeler commented on 2015-11-02 01:56

GordonGR - I've reported this as a bug upstream (bug #380). If you still want, I can take over the aur package. Either way, I've put an udpated PKGBUILD on pastebin that has the fix I'm using for the current release version. I added a step to build the old pango pkg and copy over the 3 needed files to kokua's lib64 folder, and also delete a gdk_pixbuf lib & symlinks that are causing some GTK theme issues.
It is at http://pastebin.com/VLG30XXA

Your issue looks like a video driver issue, or maybe some bad symlinks with all the libGL libs. I can't really help you much there, because I'm using the proprietary nVidia driver for my GPU. One thing I saw while doing my research is that the kokua start script (/opt/kokua-secondlife/kokua) exports this env variable:

export LD_LIBRARY_PATH=/opt/kokua-secondlife/lib:/opt/kokua-secondlife/lib64:/opt/kokua-secondlife/lib32:

so all of the libs in lib64 will get loaded before the system libs in /usr/lib. You should execute the above before running the ldd command from that hack you referenced. When I do this, I find that a symlink in /lib64 to libGLOD.so isn't necessary, and I suspect it will be the case for you too. If so, you should remove that symlink (and any others you've added that target libs from kokua's lib64). Removing these symlinks will hopefully simplify your troubleshooting a bit.

Just an FYI, in the course of my researches, I was also checking the webkit plugin (with the linker variable exported as above, of course):

ldd /opt/kokua-secondlife/bin/llplugin/libmedia_plugin_webkit.so |grep "not found"

You could also try running ldd on libGLOD.so itself to see if there's any helpful info there.

GordonGR commented on 2015-10-26 12:20

Hmm... In my case (Intel drivers), kokua fails to find the video drivers, regardless of pango version:
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

and despite the
sudo ln -s /opt/kokua-secondlife/lib64/libGLOD.so /lib64/libGLOD.so
hack described in
https://bitbucket.org/kokua/kokua-beta/raw/32155334811bc724e94ef0112f112be10091ed6b/LINUX_INSTALL_SETUP_README

Dwheeler, if you want to make a sourceforge account and report these things, you can have the aur package.

dwheeler commented on 2015-10-25 06:05

I'm also seeing the webkit plugin issue. It only seems specific to kokua (at least the official viewer and firestorm don't have the problem).

The problem looks like a pango dependency issue that will need to be addressed upstream:
2015-10-25T04:58:47Z WARNING: LLPluginInstance::load: apr_dso_load of /opt/kokua-secondlife/bin/llplugin/libmedia_plugin_webkit.so failed with error 20019 , additional info string: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: pango_matrix_get_font_scale_factors

pango_matrix_get_font_scale_factors was added to pango in 1.38 (https://github.com/GNOME/pango/blob/master/NEWS), so downgrading pango to 1.36.8-1 as a temporary workaround is fine for me - but I don't run Gnome anymore.

GordonGR commented on 2015-10-20 10:12

They did make a change[1], but the problem is I don't use Kokua, so I can't debug. Perhaps you want to tell upstream yourself? Make sure it's not just a random thing first (all viewers tend to fail to load a plugin from time to time).

[1] http://sourceforge.net/p/team-purple/kokua/tickets/347/

ArchFae commented on 2015-10-19 22:08

Upgraded to 3.8.4.37073-1 from 3.7.27.35441-1 and received an error on startup: "The Plugin media_plugin_webkit failed to load."

It worked fine before the version upgrade.

GordonGR commented on 2015-10-01 12:08

I don't think it would, but thank you anyway.

grawity commented on 2015-10-01 06:47

This would be simpler:

pkgver=3.8.4.37073
_pkgver=${pkgver//./_}
_pkgprever=${pkgver%.*}

GordonGR commented on 2015-04-05 17:39

Thank you Ravana, I had missed the update. I also see that upstream merged the opensim branch into the secondlife one (again). I will make the merge within the next days.

GordonGR commented on 2014-12-05 13:25

Fixed. Sorry it took so long, I didn't see the comment in time, my bad.