Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - kicad-pretty-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: kicad-pretty-git a-1

Git Clone URL: https://aur-dev.archlinux.org/kicad-pretty-git.git (read-only)
Package Base: kicad-pretty-git
Description: KiCad .pretty repos. Theese are the new footprint library.
Upstream URL: https://github.com/KiCad
Licenses: GPL
Submitter: nickoe
Maintainer: nickoe
Last Packager: nickoe
Votes: 26
Popularity: 1.332219
First Submitted: 2014-06-08 10:24
Last Updated: 2015-08-27 16:54

Dependencies (2)

Required by (0)

Sources (95)

Latest Comments

nickoe commented on 2015-09-28 14:16

@doragasu

I recommend to install both. But this one only includes the pretty footprints, while kicad-library-git includes the schematic symbols and 3D models...

Strictly speaking you can download the footprints from within KiCad, and hence don't need this package, but unfortunately you can not do that with the schematic symbols yet.

doragasu commented on 2015-09-28 10:30

Sorry to ask some maybe stupid questions, but... what's the difference between this and "kicad-library-git"? Will I find the same parts? Do they come with 3D models? Is there one recommended over the other? Or is it recommended to install both?

Thanks!

nickoe commented on 2015-01-25 12:38

I have now fixed this as https://github.com/nickoe/PKGBUILDs/commit/9c5d46906583c934b095f0ec6b04a1bbbce4b1aa

I believe I should not ignore it, not to mess too much with what is upstream. But I also saw that the dir was not listed in the fp-lib-table. Only time will tell what is going on.

MrBlister commented on 2015-01-25 12:23

The problem is that the directory https://github.com/KiCad/Buttons_Switches_SMD.pretty is empty, so cp fails.

Shino commented on 2015-01-25 11:42

Hi.

I get this error:

==> Starting package()...
cp: cannot stat ‘/tmp/kicad-pretty-git/src/Buttons_Switches_SMD.pretty/*’: No such file or directory
==> ERROR: A failure occurred in package().
Aborting...

How do I fix it?

nickoe commented on 2014-07-30 21:14

Reworked PKGBUILD to utilize yaourt's local git repos storage (DEVELSRCDIR)

nickoe commented on 2014-07-09 05:27

I have removed the wget dependency by using the source array, and added already existing webgetter tool curl.

spradlim commented on 2014-07-09 02:16

wget should be added to "makedepends"

spradlim commented on 2014-07-09 02:14

wget should be added as a dependency.