Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - kicad-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: kicad-git r7432.50cdd5cdf-2

Git Clone URL: https://aur-dev.archlinux.org/kicad-git.git (read-only)
Package Base: kicad-git
Description: Electronic schematic and printed circuit board (PCB) design tools
Upstream URL: http://kicad-pcb.org/
Licenses: GPL
Conflicts: kicad, kicad-bzr
Provides: kicad
Submitter: Chocobo
Maintainer: Chocobo
Last Packager: Chocobo
Votes: 57
Popularity: 1.278224
First Submitted: 2015-10-08 16:39
Last Updated: 2017-01-05 14:30

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

nickoe commented on 2014-12-28 18:06

Yes,it is for the new fp-lib-table wizard. It can be disabled with a cmake switch.

Nidhogg commented on 2014-12-28 17:56

Is webkitgtk2 required now? Without webkitgtk2 installed, I am getting the following error when I try to open eeschema.

23:21:25: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory
23:21:25: IO_ERROR: Fatal Installation Bug
missing file:
'/usr/bin/_eeschema.kiface'

argv[0]:
'/usr/bin/kicad'
from /tmp/kicad-bzr/src/kicad/common/kiway.cpp : KiFACE() : line 219

rdg commented on 2014-12-12 23:54

Ok, I have rebuilt again and it seems to be working now.

The problem started after doing a system update in which boost, icu and other things were updated. I then rebuilt a new version in which pcbnew also crashed on startup. I have checked my pacman logs and as far as I can tell my setup was fully updated and exactly the same both times. Weirdly it must have used the old versions of the libraries somehow the first time.

parched commented on 2014-12-12 22:14

@rdg, I have no problems with the current version. Have you rebuilt it against boost 1.57? If you haven't, then yeah, it won't work with 1.57.

nickoe commented on 2014-12-12 21:43

@rdg, I have not tested this version, just to be sure. I have to problems starting pcbnew stand alone or from kicad. Please fix your system.

nickoe commented on 2014-12-12 20:03

@rdg, that can't be right, I use this (a little modified), but nothing that really should matter. Are you fully up to date?

rdg commented on 2014-12-12 19:22

This is currently broken. pcbnew fails to start, other programs ok. This can be fixed by downgrading boost and lib-boost to 1.56 and icu to icu-53.1. This is not good even as a temporary solution as it breaks firefox and other things on my system.

nickoe commented on 2014-11-12 19:51

So this should soon build again with the github plugin enabled.

https://lists.launchpad.net/kicad-developers/msg15753.html

parched commented on 2014-11-10 22:37

Great, thanks nickoe.

Anyone else using Awesome WM? Do you get this bug?
https://bugs.launchpad.net/kicad/+bug/1239633

nickoe commented on 2014-11-10 17:01

Just FYI, we are just waiting for Wayne (or anyone with commit access) to update avhttp. See https://lists.launchpad.net/kicad-developers/msg15689.html.