Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - jvgs

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: jvgs 0.5.1-1

Git Clone URL: https://aur-dev.archlinux.org/jvgs.git (read-only)
Package Base: jvgs
Description: minimalistic platform game loosely based on xkcd webcomic
Upstream URL: http://jvgs.sourceforge.net/
Licenses: GPL, CCPL
Submitter: jose1711
Maintainer: jose1711
Last Packager: jose1711
Votes: 36
Popularity: 0.000055
First Submitted: 2010-02-18 20:12
Last Updated: 2015-06-12 19:56

Latest Comments

« First ‹ Previous 1 2

Cravix commented on 2013-02-17 04:02

@jose1711:
now it works again;
the problem appeared when i forgot to install lua51 before makepkg, and after i recognized that (install lua51 and rebuild), the compilation cache make it still impossible to successfully build jvgs.

so my solution is: clean ccache (rm -rf ~/.ccache) and remove srcdir then rebuild, and now it works again :)

and, please change dep "lua" to "lua51" to ensure that users have installed lua51 before building jvgs.

Cravix commented on 2013-02-17 03:01

@jose1711:
now it works again;
the problem appeared when i forgot to install lua51 before makepkg, and after i recognized that (install lua51 and rebuild), the compilation cache make it still impossible to successfully build jvgs.

so my solution is: clean ccache (rm -rf ~/.ccache) and remove srcdir then rebuild, and now it works again :)

jose1711 commented on 2013-02-13 20:21

if you want i can upload (i686 only) pkg.tar.xz for you to test

Cravix commented on 2013-02-06 13:32

got same error as ShadowfoxXXX.
add
sed -i '8i\#define lua_open luaL_newstate' src/bind/ScriptManager.cpp
before
cmake .
and it works again, but sadly when i run it, i got another error:
Error - resources/player/script.lua: resources/player/script.lua:65: invalid escape sequence near '\/'

jose1711 commented on 2013-01-27 13:10

@ShadowFoxXXX: interesting, it compiles just fine on my box.

$ pacman -Q|grep lua
lua 5.2.1-3
lua51 5.1.5-3
luajit 2.0.0-3

Anonymous comment on 2013-01-27 07:59

/tmp/yaourt-tmp-root/aur-jvgs/src/jvgs-0.5-src/src/bind/ScriptManager.cpp: In constructor ‘jvgs::bind::ScriptManager::ScriptManager()’:
/tmp/yaourt-tmp-root/aur-jvgs/src/jvgs-0.5-src/src/bind/ScriptManager.cpp:23:33: error: ‘lua_open’ was not declared in this scope
make[2]: *** [src/bind/CMakeFiles/bind.dir/ScriptManager.cpp.o] Error 1
make[1]: *** [src/bind/CMakeFiles/bind.dir/all] Error 2
make: *** [all] Error 2

jose1711 commented on 2012-12-20 17:18

@schiantaberetti: thank you, fixed

Anonymous comment on 2012-12-20 10:51

Hi,
in order to compile I had to change this line in CMakeCache.txt:
LUA_INCLUDE_DIR:PATH=/usr/include
in this one:
LUA_INCLUDE_DIR:PATH=/usr/include/lua5.1

jose1711 commented on 2010-10-06 19:57

thank you, fixed

mar77i commented on 2010-10-06 00:05

missing mesa dependency?

/SDL_opengl.h:46:60: fatal error: GL/gl.h: No such file or directory
/usr/include/GL/gl.h is owned by mesa 7.8.2-3