Notice: Undefined variable: name in /srv/http/vhosts/ on line 248

Package Details: jd-gui 1.4.0-3

Git Clone URL: (read-only)
Package Base: jd-gui
Description: A standalone graphical utility that displays Java source codes of .class files
Upstream URL:
Licenses: GPL3
Conflicts: jd-gui-bin
Provides: jd-gui
Submitter: simon04
Maintainer: simon04
Last Packager: simon04
Votes: 18
Popularity: 2.545407
First Submitted: 2015-05-27 20:51
Last Updated: 2015-11-30 15:19

Latest Comments

crccw commented on 2016-02-12 12:51

Same "Could not find tools.jar" error with me. JAVA_HOME is set.
But you can use jd-gui-bin if you just want the binary

daurnimator commented on 2016-01-15 00:31

> Which JDK are you using?

$ pacman -Qs jdk
local/jdk7-openjdk 7.u91_2.6.3-3
OpenJDK Java 7 development kit
local/jre7-openjdk 7.u91_2.6.3-3
OpenJDK Java 7 full runtime environment
local/jre7-openjdk-headless 7.u91_2.6.3-3
OpenJDK Java 7 headless runtime environment
local/jre8-openjdk 8.u66-1
OpenJDK Java 8 full runtime environment
local/jre8-openjdk-headless 8.u66-1
OpenJDK Java 8 headless runtime environment

> Did you set JAVA_HOME?

No? what needs to be done?

simon04 commented on 2016-01-05 07:49

Which JDK are you using? Did you set JAVA_HOME? I assume it's some sort of misconfiguration.

daurnimator commented on 2016-01-05 02:55

Has been failing for me for a few months:

:distTar UP-TO-DATE
:distZip UP-TO-DATE
:doFirstDistTar UP-TO-DATE
:doFirstDistZip UP-TO-DATE
:compileJava UP-TO-DATE
:processResources UP-TO-DATE
:classes UP-TO-DATE
:api:compileJava FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':api:compileJava'.
> Could not find tools.jar

simon04 commented on 2015-12-01 12:21

@Kuci: I disagree, see
Also namcap does not require this dependency being added.

The_K commented on 2015-12-01 11:58

patch should be added as a make dependency.

Corax commented on 2015-11-24 22:15

Thanks for the fix, 1.4.0-2 builds fine. And good idea reporting upstream :)

simon04 commented on 2015-11-09 15:35

Thank you for reporting.

Build fixed in 1.4.0-2.

simon04 commented on 2015-11-09 15:28

I reported upstream:

Corax commented on 2015-11-09 13:14

Does not build with gradle 2.8 as one of the dependencies of jd-gui (Spock) depends on groovy 2.3.
Easy fix: in src/jd-gui-1.4.0/build.gradle, replace 'groovy-2.3' with 'groovy-2.4'.