Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: intellij-idea-ue-eap 2017.1.171.2613.7-1

Git Clone URL: https://aur-dev.archlinux.org/intellij-idea-ue-eap.git (read-only)
Package Base: intellij-idea-ue-eap
Description: Early access version of the upcoming version of Intellij Idea IDE (ultimate version)
Upstream URL: http://www.jetbrains.com/idea/
Keywords: ide java
Licenses: custom
Submitter: Kendos_Kenlen
Maintainer: artafinde
Last Packager: artafinde
Votes: 27
Popularity: 1.227797
First Submitted: 2014-09-06 20:06
Last Updated: 2017-01-25 20:17

Pinned Comments

Magotchi commented on 2016-01-15 20:56

If you would rather use your system's JDK than IDEA's custom JDK, do the following:
echo /usr/lib/jvm/default > ~/.IntelliJIdea2016.2/config/idea.jdk

I use Infinality's custom JDK on my system, so I found that the fonts were looking much different with IDEA's JDK.

Edit: updated config directory path to reflect latest version

Latest Comments

1 2 3 4 5 6 ... Next › Last »

artafinde commented on 2016-12-07 10:57

Package is up to date.
Last Updated: 2016-12-07 10:52

gastonovic commented on 2016-12-07 10:55

A new build (2016.3 163.9166.20) is available.
Please update

Weby commented on 2016-08-29 10:40

Last update breaks the shortcuts in /usr/bin

Change
ln -s "${pkgdir}/opt/${pkgname}/bin/idea.sh" "${pkgdir}/usr/bin/idea-ue-eap"
to
ln -s "/opt/${pkgname}/bin/idea.sh" "${pkgdir}/usr/bin/idea-ue-eap"

to get it working again.

(This comes when you update/install from yaourt, no idea if you makepkg yourself)

ptxmac commented on 2016-05-15 08:39

eap 2016.2 have been released: https://confluence.jetbrains.com/display/IDEADEV/IDEA+2016.2+EAP

artafinde commented on 2016-04-06 07:07

@itti: you are right, I forgot to quote the variable. Thanks for pointing it out.

itti commented on 2016-04-04 07:57

Once again built the updated package with an unchanged PKGBUILD. Still the bundled JRE seems to be missing:

[itti@edi ~]$ pacman -Ql intellij-idea-ue-eap | grep jre
[itti@edi ~]$

artafinde commented on 2016-03-30 12:44

@itti: Normally one would change only the "_use_no_jdk_archive" variable to indicate that {s}he doesn't want to use the bundled JRE. If you want to keep the bundled JRE don't modify the PKGBUILD. The other variable is for me to save me from changing too many things between releases as Jetbrains seems to have two patterns in their releases (one which provide a no-jdk archive and one without).

itti commented on 2016-03-29 08:43

What is the purpose of having two variables (_user_no_jdk_archive, _nojdkrelease) to track whether the user wants the bundled JRE or not? At least for me the latest PKGBUILD didn't handle those correctly. I wasn't able to prevent makepkg from deleting the jre subfolder in the end. Wouldn't it be easier to just decide on what archive to download and package that? Why would i download the jre just to have it deleted anyway?

Magotchi commented on 2016-03-26 16:37

That 145.596.7 PKGBUILD works great. Thanks.

artafinde commented on 2016-03-26 02:27

Can someone check the PKGBUILD here [1]. I have very limited data and the ~500 Mb is going to kill my mobile plan (still in vacations). (JetBrains can't stick to a pattern for releases - they keep changing their archive names).

[1] https://ptpb.pw/lGNC