Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: hugo-bin 0.18.1-1

Git Clone URL: https://aur-dev.archlinux.org/hugo-bin.git (read-only)
Package Base: hugo-bin
Description: A Fast and Flexible Static Site Generator built in Go - Precompiled binary from official repository
Upstream URL: https://gohugo.io/
Keywords: generator go static web
Licenses: Apache
Conflicts: hugo
Provides: hugo
Submitter: neitsab
Maintainer: banbanchs
Last Packager: neitsab
Votes: 48
Popularity: 2.423913
First Submitted: 2016-10-31 19:03
Last Updated: 2016-12-31 17:12

Dependencies (4)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

neitsab commented on 2017-01-13 13:13

I'll be away from keyboard and good Internet connectivity for the next few months, therefore this package needs a new maintainer.
If somebody feels up to it, then just shoot me an email or say in the comments and I'll add you as co-maintainer.
If nobody has stepped up tomorrow, I'll disown the package so that somebody else can take it.
Cheers!

neitsab commented on 2016-10-31 19:10

I just pushed hugo-bin to the AUR. Changelog:

- update to v0.17
- add shell autocompletion script and man generation steps (@romansaveljev and @masterme120)
- append -bin to package name to follow Arch packaging standards (@runical)
- add proper support for ARM while maintaining compatibility with helper scripts
(updpkgsums etc.) (@runical)
- add optdepends for AsciiDoc and reStructuredText support (@doskoi)
- add pygmentize to optdepend (@m4ng0squ4sh)
- add provides=() and conflicts=() arrays to prevent accidental overwrite
- update upstream URL

I also requested the merge of hugo into hugo-bin to leave the namespace to its due owner, hugo-src.
By the way I'm open to co-maintainership, be it from current maintainer or another interested user. Cheers!

neitsab commented on 2016-10-31 16:23

neitsab filed an orphan request for hugo:

No sign of maintainer since last update in June, package has been
flagged out-of-date for three weeks, its name is incorrect (should be
hugo-bin since it downloads pre-built binaries from upstream), several
user requests pending in the comments.

whoseos commented on 2016-10-26 10:43

I've uploaded an updated PKGBUILD suitable for v0.17 (with changed archive layout and changed source paths) including pygments as optional dependency:
http://ix.io/1zCS

fusion809 commented on 2016-10-08 19:21

@m4ng0squ4sh I've added your suggestion to my hugo-src package (https://aur.archlinux.org/packages/hugo-src).

m4ng0squ4sh commented on 2016-08-29 06:56

Please add the pygmentize package as optional dependency.

masterme120 commented on 2016-08-11 04:42

I would suggest adding these two lines to package() to enable autocompletion:

mkdir -p ${pkgdir}/usr/share/bash-completion/completions
${srcdir}/${pkgname} gen autocomplete --completionfile="${pkgdir}/usr/share/bash-completion/completions/${pkgname}"

doskoi commented on 2016-05-14 16:03

External helpers like asciidoc should be added as optional dependencies I think (see https://gohugo.io/content/supported-formats/).

skrylar commented on 2016-05-01 02:53

The AUR repository 404's.
[edit] Seems to work if cloned at the CLI. Weird, since some packages DO show up in the web browser.

runical commented on 2016-03-21 21:19

As promised, I overhauled the PKGBUILD to be more correct and more clear based on the syncthing-bin PKGBUILD [1]. It also catches all versions of ARM as long as they are added to the arch array. I didn't get to the build from source PKGBUILD yet, but I'll get there sometime this week.

[1] https://gist.github.com/runical/0689c6ceb38a6e786f34