Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - home-assistant

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: home-assistant 0.37.1-1

Git Clone URL: https://aur-dev.archlinux.org/home-assistant.git (read-only)
Package Base: home-assistant
Description: Home Assistant is an open-source home automation platform running on Python 3
Upstream URL: https://home-assistant.io/
Licenses: MIT
Conflicts: python-home-assistant, python-home-assistant-git
Replaces: python-home-assistant
Submitter: kamaradclimber
Maintainer: kamaradclimber
Last Packager: kamaradclimber
Votes: 6
Popularity: 1.198266
First Submitted: 2016-10-09 12:17
Last Updated: 2017-02-04 09:41

Latest Comments

1 2 3 Next › Last »

kamaradclimber commented on 2017-02-02 09:42

@bluenote, let me know if I can change things in this package.

bluenote commented on 2017-02-01 20:19

kamarad: I'm guessing that it's permissions causing my problems. I'll check next time it happens, but certainly this upgrade I noted root ownership on some things, and problems cleared up when I fixed the ownership.

kamaradclimber commented on 2017-01-19 09:10

@bluenote, could you detail the issue you encountered?

python-async-timeout and python-voluptuous are dependencies of this package.
maybe their version constraints are wrong (I'm using 1.1.0 and 0.9.3 respectively).

Let me know which packages version you are using and I'll update the constraints.

bluenote commented on 2017-01-18 22:49

Every couple of versions I end up missing dependencies - this time it's async_timeout and voluptuous (well, might just be needed newer versions, I can't say for certain) which I end up installing with pip3. Am I doing this wrong?

laser_b commented on 2016-12-31 09:13

The .SRCINFO is out of sync with the PKGBUILD. In the PKGBUILD the version is 0.35.2, but in the .SRCINFO it is only 0.35.
Please run `makepkg --printsrcinfo > .SRCINFO` [1].

[1]: https://wiki.archlinux.org/index.php/Arch_User_Repository#Uploading_packages

kamaradclimber commented on 2016-11-30 11:12

thanks for the feedback @j0s. I'll fix that if necessary on the next release indeed

j0s commented on 2016-11-30 09:45

Just noticed that this was fixed in https://github.com/home-assistant/home-assistant/commit/95b439fbd5ad96966dfe1176697c6ee4731a6207
Guess we'll just have to wait for home-assistant 0.34 which is due in a couple of days.

j0s commented on 2016-11-30 09:34

Since python-aiohttp was upgraded to 1.1.5-1, home-assistant fails to start. aiohttp 1.0.5 is required:

nov 30 09:26:06 hass[695]: pkg_resources.DistributionNotFound: The 'aiohttp==1.0.5' distribution was not found and is required by homeassistant
nov 30 09:26:06 systemd[1]: home-assistant.service: Main process exited, code=exited, status=1/FAILURE

kamaradclimber commented on 2016-10-21 18:32

@bluenote, could you precise where you get this error (during package build or when launching home assistant)?
Maybe add a stacktrace or any error message you see.

bluenote commented on 2016-10-21 00:41

I get complaints about pubnub and websocket being missing, I'm not sure if this is me or the package?