Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: gtk4-update-icon-cache-git 3.89.3.r119.gf251c5bf94-1

Git Clone URL: https://aur-dev.archlinux.org/gtk4-git.git (read-only)
Package Base: gtk4-git
Description: GTK+ icon cache updater
Upstream URL: http://www.gtk.org/
Licenses: LGPL
Submitter: andrewSC
Maintainer: andrewSC
Last Packager: andrewSC
Votes: 13
Popularity: 0.501889
First Submitted: 2016-11-18 20:17
Last Updated: 2017-02-03 15:00

Latest Comments

1 2 3 4 5 6 ... Next › Last »

andrewSC commented on 2017-02-03 17:51

shoober420: I just rebuilt this package without error and I do not have glslc installed. I assume you've tried completely rebuilding this package from scratch?

shoober420 commented on 2017-02-03 17:31

I tried installing glslc-git and that also compiles with an error. So I'm going to have to wait and see if its because I don't have glslc. That seems to be the most likely reason. glslc-git should be added to the dependencies.

shoober420 commented on 2017-02-03 17:18

I've ran into another compile error. Here's the output.

copying selected object files to avoid basename conflicts...
ar: `u' modifier ignored since `D' is the default (see `U')
GISCAN Gdk-noinst-4.0.gir
In file included from /usr/include/limits.h:25:0,
from /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include-fixed/limits.h:168,
from /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include-fixed/syslimits.h:7,
from /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include-fixed/limits.h:34,
from /usr/lib/glib-2.0/include/glibconfig.h:11,
from /usr/include/glib-2.0/glib/gtypes.h:32,
from /usr/include/glib-2.0/glib/galloca.h:32,
from /usr/include/glib-2.0/glib.h:30,
from /home/asd/Downloads/packages/gtk4-git/src/gtk+/gdk/gdkconfig.h:13,
from /home/asd/Downloads/packages/gtk4-git/src/gtk+/gdk/gdk.h:30,
from /tmp/g-ir-cpp-Z9oqm7.c:4:
/usr/include/features.h:331:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
# warning _FORTIFY_SOURCE requires compiling with optimization (-O)
^~~~~~~
GISCAN GdkX11-noinst-4.0.gir
In file included from /usr/include/limits.h:25:0,
from /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include-fixed/limits.h:168,
from /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include-fixed/syslimits.h:7,
from /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include-fixed/limits.h:34,
from /usr/lib/glib-2.0/include/glibconfig.h:11,
from /usr/include/glib-2.0/glib/gtypes.h:32,
from /usr/include/glib-2.0/glib/galloca.h:32,
from /usr/include/glib-2.0/glib.h:30,
from /home/asd/Downloads/packages/gtk4-git/src/gtk+/gdk/gdkconfig.h:13,
from /home/asd/Downloads/packages/gtk4-git/src/gtk+/gdk/gdk.h:30,
from /home/asd/Downloads/packages/gtk4-git/src/gtk+/gdk/x11/gdkx.h:28,
from /tmp/g-ir-cpp-b9YZxP.c:4:
/usr/include/features.h:331:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
# warning _FORTIFY_SOURCE requires compiling with optimization (-O)
^~~~~~~
make[4]: Leaving directory '/home/asd/Downloads/packages/gtk4-git/src/gtk+/gdk'
make[3]: Leaving directory '/home/asd/Downloads/packages/gtk4-git/src/gtk+/gdk'
make[2]: Leaving directory '/home/asd/Downloads/packages/gtk4-git/src/gtk+/gdk'
Making all in gsk
make[2]: Entering directory '/home/asd/Downloads/packages/gtk4-git/src/gtk+/gsk'
Missing glslc. See https://github.com/google/shaderc
make[2]: *** [Makefile:1598: resources/vulkan/border-clip-rounded.frag.spv] Error 1
make[2]: Leaving directory '/home/asd/Downloads/packages/gtk4-git/src/gtk+/gsk'
make[1]: *** [Makefile:719: all-recursive] Error 1
make[1]: Leaving directory '/home/asd/Downloads/packages/gtk4-git/src/gtk+'
make: *** [Makefile:615: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

andrewSC commented on 2017-02-03 15:01

shoober420: Turns out there's a bug in documentation generation in master so I've disabled that in the PKGBUILD for now. I'll re-enable it once it's fixed.

edit: Here's the tracker https://bugzilla.gnome.org/show_bug.cgi?id=778144

shoober420 commented on 2017-02-01 22:16

I've been getting this error for sometime now. I thought it was just a bad commit causing the error, but it might be the PKGBUILD.

DOC Preparing build
DOC Scanning header files
DOC Introspecting gobjects
gtk4-scan.c: In function ‘output_object_args’:
gtk4-scan.c:1305:20: warning: implicit declaration of function ‘gtk_widget_class_list_style_properties’ [-Wimplicit-function-declaration]
properties = gtk_widget_class_list_style_properties (GTK_WIDGET_CLASS (class), &n_properties);
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
gtk4-scan.c:1305:18: warning: assignment makes pointer from integer without a cast [-Wint-conversion]
properties = gtk_widget_class_list_style_properties (GTK_WIDGET_CLASS (class), &n_properties);
^
.libs/gtk4-scan.o: In function `main':
gtk4-scan.c:(.text.startup+0x136e): undefined reference to `gtk_widget_class_list_style_properties'
collect2: error: ld returned 1 exit status
Linking of scanner failed:
make[4]: *** [Makefile:1345: scan-build.stamp] Error 1
make[4]: Leaving directory '~/Downloads/packages/gtk4-git/src/gtk+/docs/reference/gtk'
make[3]: *** [Makefile:554: all-recursive] Error 1
make[3]: Leaving directory '~/Downloads/packages/gtk4-git/src/gtk+/docs/reference'
make[2]: *** [Makefile:556: all-recursive] Error 1
make[2]: Leaving directory '~/Downloads/packages/gtk4-git/src/gtk+/docs'
make[1]: *** [Makefile:719: all-recursive] Error 1
make[1]: Leaving directory '~/Downloads/packages/gtk4-git/src/gtk+'
make: *** [Makefile:615: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

andrewSC commented on 2016-12-12 17:32

DeadMetaler: I had added gtk3 as a conflict because if you try to install this package with gtk3 installed, you're going to get conflicts because of pre-existing files (which is supposed to happen as those files are shared between gtk4/gtk3). I wanted to avoid telling people to (--force) with their pacman -U but thinking about it more, using --force should ultimately be up to them to decide. I'll remove the conflicts from the PKGBUILD.

DeadMetaler commented on 2016-12-09 20:40

Why gtk4 replace gtk3? I think it should work together like now it doing gtk3 + gtk2.

shoober420 commented on 2016-12-02 18:41

It's cool, thanks again for maintaining this.

andrewSC commented on 2016-12-01 14:27

shoober420: I totally understand the annoyance however, since libepoxy in the official repos satisfies the configure.ac version requirement for epoxy, I'm going to have to stay with what's currently in the PKGBUILD.

shoober420 commented on 2016-11-30 22:33

Very minor thing. I use libepoxy-git and have to edit the PKGBUILD to simply be libepoxy to satisfy the dependencies.