Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - grive-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: grive-git 434.7bbb01c-2

Git Clone URL: https://aur-dev.archlinux.org/grive-git.git (read-only)
Package Base: grive-git
Description: An open source Linux client for Google Drive with support for the new Drive REST API and partial sync
Upstream URL: https://github.com/vitalif/grive2
Keywords: drive git Google share sync
Licenses: GPL2
Conflicts: grive
Provides: grive=434.7bbb01c
Submitter: ilpianista
Maintainer: edh
Last Packager: edh
Votes: 70
Popularity: 0.615406
First Submitted: 2012-04-29 15:20
Last Updated: 2017-01-07 14:06

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

hongy19 commented on 2013-06-19 14:19

I also need to change "ljson-c" to "ljson" in order to solve missing "ljson-c" issue.

PKGBUILD
-DCMAKE_EXE_LINKER_FLAGS=-ljson-c

hongy19 commented on 2013-06-19 01:21

this scrip also need qt4 for compile?

J-Wreck commented on 2013-06-18 14:53

Should be fixed now

Anonymous comment on 2013-06-18 08:00

Still getting errors when trying to build.

Fixed one by installing yajl

Fixed another by adding the lines

#define PACKAGE "grive"
#define PACKAGE_VERSION "git"

to libgrive/src/bfd/SymbolInfo.cc as suggested by bananaoomarang

The current error I'm receiving is:

-- Installing: /home/niksko/AUR/grive-git/pkg/grive-git/usr/bin/bgrive
CMake Error at bgrive/cmake_install.cmake:52 (FILE):
file INSTALL cannot find
"/home/niksko/AUR/grive-git/src/grive/bgrive/doc/grive.1".
Call Stack (most recent call first):
cmake_install.cmake:39 (INCLUDE)


make: *** [install] Error 1
==> ERROR: A failure occurred in package().
Aborting...

dobo commented on 2013-06-17 13:38

If it doesn't compile try this workaround
https://gist.github.com/dobo90/5796923

J-Wreck commented on 2013-01-29 17:24

@mountpeaks, are you building with the latest sources? It builds fine for me

tastyminerals commented on 2013-01-28 21:56

[ 95%] Building CXX object libgrive/CMakeFiles/unittest.dir/test/util/ConfigTest.cc.o
/tmp/yaourt-tmp-tasty-minerals/aur-grive-git/src/grive/libgrive/test/util/ConfigTest.cc:39:44: error: no ‘void grut::ConfigTest::TestInitialiseWithNoPath()’ member function declared in class ‘grut::ConfigTest’
/tmp/yaourt-tmp-tasty-minerals/aur-grive-git/src/grive/libgrive/test/util/ConfigTest.cc:48:42: error: no ‘void grut::ConfigTest::TestInitialiseWithPath()’ member function declared in class ‘grut::ConfigTest’
make[2]: *** [libgrive/CMakeFiles/unittest.dir/test/util/ConfigTest.cc.o] Error 1
make[1]: *** [libgrive/CMakeFiles/unittest.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build grive-git.
==> Restart building grive-git ? [y/N]

J-Wreck commented on 2012-12-11 01:00

As of the last update (Dec 6), the package should build fine.

bananaoomarang commented on 2012-12-10 20:33

@temoto

I just figured out a patch to get it to build on my box, just a couple of small problems. Seems to work now.

http://pastebin.com/Df4HPnL1

bananaoomarang commented on 2012-12-10 17:47

@temoto

Fixed by adding:

#define PACKAGE "grive"
#define PACKAGE_VERSION "git"

To the offending SymbolInfo.cc file.

http://stackoverflow.com/questions/11748035/binutils-bfd-h-wants-config-h-now