Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - godot-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: godot-git 2.2.r6022.2c8a172-1

Git Clone URL: https://aur-dev.archlinux.org/godot-git.git (read-only)
Package Base: godot-git
Description: Godot Game Engine: An advanced, feature packed, multi-platform 2D and 3D game engine.
Upstream URL: http://www.godotengine.org
Keywords: 2D 3D engine game gamedev
Licenses: MIT
Conflicts: godot
Provides: godot
Submitter: Matteotom
Maintainer: pollopolis
Last Packager: pollopolis
Votes: 24
Popularity: 0.007408
First Submitted: 2014-02-10 06:42
Last Updated: 2016-12-20 13:36

Latest Comments

1 2 3 Next › Last »

yacuken commented on 2016-12-11 23:16

Building is too long. And scons don't use MAKEFLAGS. Can you add -j$(nproc) to build()?

hickop commented on 2016-11-11 10:26

Added spaces in version.py break pkgver(), here is a working PKGBUILD:
http://pastie.org/10960344

pollopolis commented on 2016-10-04 13:06

ryukinix, does it fail to compile? to run? What error message are you getting?

ryukinix commented on 2016-10-04 06:53

I just don't understand it. This version just doesn't works in my machine and the official binary for 2.1 version works. Why?

Zatherz commented on 2016-08-21 17:36

The clang dependency should be in makedepends, not in depends.

Zatherz commented on 2016-08-08 14:36

Please add a dependency on 'clang' and replace line 50 in the PKGBUILD with 'scons platform=x11 target=release_debug CXX=clang++'

zaps166 commented on 2016-05-19 10:31

Currently Godot doesn't work properly with GCC 6. As a temporary workaround Clang should be used instead.

TingPing commented on 2015-12-22 01:13

libxinerama is a required dep: http://godotengine.org/projects/godot-engine/wiki/Compiling_for_Linux

pkg-config is not a required makedep as it is part of core.

shackra commented on 2015-11-20 02:53

`pkg-config` is a missing `makedepend` dependency.

presidentwolf commented on 2015-05-22 23:37

1.1 was officially released today.