Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - gnutls28

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: gnutls28 3.3.24-1

Git Clone URL: https://aur-dev.archlinux.org/gnutls28.git (read-only)
Package Base: gnutls28
Description: A library which provides a secure layer over a reliable transport layer (legacy version)
Upstream URL: http://gnutls.org/
Licenses: GPL3, LGPL2.1
Conflicts: libgnutls28
Provides: libgnutls28
Submitter: SunRed
Maintainer: None
Last Packager: zman0900
Votes: 16
Popularity: 0.303466
First Submitted: 2015-12-05 01:50
Last Updated: 2016-07-27 06:38

Pinned Comments

zman0900 commented on 2016-08-20 22:18

See https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

You need to run `gpg --recv-keys 1F42418905D8206AA754CCDC29EE58B996865171`

Latest Comments

1 2 Next › Last »

zman0900 commented on 2016-08-20 22:18

See https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

You need to run `gpg --recv-keys 1F42418905D8206AA754CCDC29EE58B996865171`

LizziAS commented on 2016-08-13 01:48

here it is:

gpg --keyserver pgp.mit.edu --recv-keys 9D5EAAF69013B842

LizziAS commented on 2016-08-13 01:36

Validating source files with sha256sums...
gnutls-3.3.24.tar.xz ... Passed
gnutls-3.3.24.tar.xz.sig ... Skipped
==> Verifying source file signatures with gpg...
gnutls-3.3.24.tar.xz ... FAILED (unknown public key 9D5EAAF69013B842)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build gnutls28.

and so then i do:

sudo pacman-key -r 9D5EAAF69013B842
[sudo] password for lizzias:
gpg: key 29EE58B996865171: "Nikos Mavrogiannopoulos nmav@gnutls.org" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
==> Updating trust database...
gpg: next trustdb check due at 2016-10-19

as well as this:

sudo pacman-key --lsign-key 9D5EAAF69013B842
-> Locally signing key 9D5EAAF69013B842...
==> Updating trust database...
gpg: next trustdb check due at 2016-10-19

AND THEN RESTART THE BUILD.

but on the restart of the build, the error persists.

what else is there to do?

also tried:

sudo pacman-key --refresh-keys

but the package still wont build

zman0900 commented on 2016-06-17 22:44

There is talk on the mailing list about this: http://article.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/8588

I'll update to use one of the mirrors for now. This should be safe since the file is signed.

pschichtel commented on 2016-06-17 19:55

This is a working mirror: http://mirrors.dotsrc.org/gcrypt/gnutls/v3.3/

pschichtel commented on 2016-06-17 19:40

The files seem to be missing on their FTP server...

CurtisLeeBolin commented on 2016-06-01 14:35

Need to update validpgpkeys

Anonymous comment on 2016-05-27 20:35

I am getting a "failed to verify package integrity" whenever I try to install.

zman0900 commented on 2016-04-23 23:29

You don't want to just change that `make -k check` to `make` - that will just build the code twice. If you want to build without checks, use `makepkg -si --nocheck`. Even with checks, add the "-s" to make sure dependencies are installed.

But hopefully you won't need to disable checks. I added a patch from the gnutls devs to fix the broken test.

yu.development commented on 2016-04-23 03:31

edit PKGBUILD file then change this line:
make -k check
to
make
then you can build package :3
makepkg -i