Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - gmsh

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: gmsh 2.16.0-1

Git Clone URL: https://aur-dev.archlinux.org/gmsh.git (read-only)
Package Base: gmsh
Description: An automatic 3D finite element mesh generator with pre and post-processing facilities.
Upstream URL: http://www.geuz.org/gmsh/
Licenses: custom
Submitter: S1G1
Maintainer: gborzi
Last Packager: gborzi
Votes: 40
Popularity: 0.053374
First Submitted: 2006-04-04 23:31
Last Updated: 2017-01-03 21:17

Latest Comments

1 2 3 4 5 6 ... Next › Last »

gborzi commented on 2016-11-02 14:08

Fixed, thanks.

eolianoe commented on 2016-11-02 12:18

The cheksums are not good and with the right archive there is no need of the svn information ('svn-20161031'), see [a]

[a] http://onelab.info/pipermail/gmsh/2016/010909.html

gdolle commented on 2016-07-21 13:04

Hi @gborzi, you should add an optional dependency to `petsc` or desactivate it in the cmake otherwise it might breaks gmsh during updates.

gborzi commented on 2016-07-19 20:31

hdf5 is needed by med, and med needs hdf5 version 1.8 to work properly. Or you can try a different approach, which is the one I use and works fine for me.
Compile med with hdf5 version 1.10 using the patch that I made available here http://pastebin.com/WpUsW9uL
(and the other patches). Then you will have gmsh compiled with working MED support without the need to downgrade to hdf 1.8.

jancici commented on 2016-07-19 20:12

I am not able to start gmsh because it fail to load shared libraries libhdf5.so.10.

I need to downgrad hdf5 to 1.8.17-1 {https://archive.archlinux.org/packages/h/hdf5_18/}

Please, can someone solve it? thank you

pizzooid commented on 2016-06-08 15:06

Please add https://aur.archlinux.org/packages/hdf5-1.8 as a dependency

fredericva commented on 2016-05-17 13:29

Compilation fails with GCC 6, but the Debian guys already have a (trivial) patch:

Description: Fix narrow conversion error with GCC-6
Author: Anton Gladky <gladk@debian.org>
Bug-Debian: https://bugs.debian.org/811792
Last-Update: 2016-01-30

Index: gmsh-2.12.0-source/Fltk/FlGui.cpp
--- gmsh-2.12.0-source.orig/Fltk/FlGui.cpp
+++ gmsh-2.12.0-source/Fltk/FlGui.cpp
@@ -370,7 +370,7 @@ FlGui::FlGui(int argc, char **argv)
// nothing to do here
- static char gmsh32x32[] = {
+ static unsigned char gmsh32x32[] = {
0x00, 0x00, 0x00, 0x00, 0x00, 0x80, 0x01, 0x00, 0x00, 0x40, 0x03, 0x00,
0x00, 0x40, 0x03, 0x00, 0x00, 0x20, 0x07, 0x00, 0x00, 0x20, 0x07, 0x00,
0x00, 0x10, 0x0f, 0x00, 0x00, 0x10, 0x0f, 0x00, 0x00, 0x08, 0x1f, 0x00,
@@ -384,7 +384,7 @@ FlGui::FlGui(int argc, char **argv)
0xff, 0xff, 0xff, 0xff, 0x00, 0x00, 0x00, 0x00};
((const char*)XCreateBitmapFromData(fl_display, DefaultRootWindow(fl_display),
- gmsh32x32, 32, 32));
+ (char*)(gmsh32x32), 32, 32));

graph[0]->getWindow()->show(argc >0 ? 1 : 0, argv);

mickele commented on 2016-05-13 22:49

After hdf5 upgrade to 1.10 gmsh doesn't create valid med file. Downgrading to hdf5-1.8 solves the problem. So I created a package hdf5-1.8 available at https://aur.archlinux.org/packages/hdf5-1.8.
med and gmsh must be modified to link to hdf5-1.8. PKGBUILD of med-salome links to hdf5-1.8 .
To link gmsh to hdf5-1.8 I added line

-DHDF5_LIB=/opt/hdf5-1.8/lib/libhdf5.so \

to cmake command

gborzi commented on 2016-05-03 11:45

After the hdf5 upgrade the package needs to be recompiled.

mickele commented on 2016-03-30 08:48

Thanks for your help.
In the meantime I sent a message to gmsh mailing list asking for suggestions.