Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - global

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: global 6.5.6-1

Git Clone URL: https://aur-dev.archlinux.org/global.git (read-only)
Package Base: global
Description: A source code tag system
Upstream URL: http://www.gnu.org/software/global/
Licenses: GPL
Submitter: None
Maintainer: ptrv
Last Packager: ptrv
Votes: 108
Popularity: 1.975614
First Submitted: 2007-03-05 00:02
Last Updated: 2017-01-07 10:07

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

migrev commented on 2014-09-09 15:21

@ackalker: Bump with your proposed changes, also got rid of libtool per @kolewu comment. Please check that everything works for you and thanks for the feedback.

ackalker commented on 2014-09-09 14:37

python2 -> python2-pygments
This should pull in python2 as well.

ackalker commented on 2014-09-09 14:31

Ah, and please also fix /usr/share/gtags/script/pygments_parser.py to use:
#!/usr/bin/python2

The Pygments plug-in parser isn't compatible with Python 3.x.

ackalker commented on 2014-09-09 14:30

Ah, and please also fix /usr/share/gtags/script/pygments_parser.py to use:
#!/usr/bin/env python2

The Pygments plug-in parser isn't compatible with Python 3.x.

ackalker commented on 2014-09-09 14:22

Please add optional dependency on python2: to use the Pygments plug-in parser.
This was newly added in GLOBAL 6.3.2, see [1],[2].
Thanks in advance.

[1]: http://lists.gnu.org/archive/html/info-global/2014-09/msg00000.html
[2]: /usr/share/gtags/PLUGIN_HOWTO.pygments

kolewu commented on 2014-04-06 12:32

The plugins configured in the default gtags.conf don't work cause the are called via .la-files. So you have to either change option '!libtool' to 'libtool' or directly use the .so-libs by including this before configure:

sed -i 's/\.la/.so/g' gtags.conf.in

ackalker commented on 2013-02-06 05:28

Updated to version 6.2.7, also fixed install info file:
PKGBUILD: http://pastie.org/6077224
global.install: http://pastie.org/6077227

jedbrown commented on 2012-06-03 15:23

This version dumps core for me. Updating to 6.2.4 worked.

Schnouki commented on 2012-02-24 16:03

Bonus point: add ctags to optdepends and "--with-exuberant-ctags=/usr/bin/ctags" to ./configure so you can use the exuberant-ctags plugin.

Schnouki commented on 2012-02-24 14:49

Updated for 6.2.1:
- PKGBUILD: http://pastebin.com/FHYqMBJn
- global.install: http://pastebin.com/nrd18gd7

Changes:
- version bump
- add a missing dependency reported by namcap
- add "!emptydirs" to options
- don't include global.install in source array
- don't create symlink to gtags.el in install but in PKGBUILD (so that it belongs to the package and can be removed)
- don't use absolute paths in the install file