Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - github-notify

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: github-notify 0.1.2.1-1

Git Clone URL: https://aur-dev.archlinux.org/github-notify.git (read-only)
Package Base: github-notify
Description: GitHub notification notifier
Upstream URL: https://www.github.com/Xandaros/GithubNotify
Licenses: custom
Submitter: Xandaros
Maintainer: Xandaros
Last Packager: Xandaros
Votes: 3
Popularity: 0.000012
First Submitted: 2015-05-16 18:57
Last Updated: 2016-07-19 06:11

Latest Comments

Xandaros commented on 2016-07-15 11:45

There you go - the dependency errors should be fixed now.

Btw, technically this is an upstream problem - the dependencies were set in such a way that they were incompatible with GHC 8. I just happen to also be upstream :P

ptkato commented on 2016-07-14 18:15

I'm confused, getting dependency errors:

Resolving dependencies...
cabal: Could not resolve dependencies:
trying: GithubNotify-0.1.0.0 (user goal)
next goal: base (dependency of GithubNotify-0.1.0.0)
rejecting: base-4.9.0.0/installed-4.9... (conflict: GithubNotify => base>=4.8 && <4.9)
rejecting: base-4.9.0.0, base-4.8.2.0, base-4.8.1.0, base-4.8.0.0,
base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1, base-4.6.0.0,
base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0, base-4.3.1.0,
base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0, base-4.1.0.0,
base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from non-upgradeable package requires installed instance)
Dependency tree exhaustively searched.

==> ERROR: A failure occurred in build().
Aborting...
:: failed to build github-notify package(s)

awilliamson commented on 2015-05-17 18:07

PKGBUILD requires 'cabal update' to be ran, otherwise building will fail as package list for hackage.haskell.org doesn't exist.