Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - gimp-plugin-resynthesizer-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: gimp-plugin-resynthesizer-git 2.0.r15.g462b0b7-3

Git Clone URL: https://aur-dev.archlinux.org/gimp-plugin-resynthesizer-git.git (read-only)
Package Base: gimp-plugin-resynthesizer-git
Description: Suite of gimp plugins for texture synthesis (like heal-selection). Git-Version
Upstream URL: https://github.com/bootchk/resynthesizer
Keywords: heal heal-selection
Licenses: GPL2
Conflicts: gimp-resynth, gimp-resynth-git
Provides: gimp-plugin-resynthesizer=2.0
Submitter: TrialnError
Maintainer: TrialnError
Last Packager: TrialnError
Votes: 197
Popularity: 3.236987
First Submitted: 2014-10-09 10:24
Last Updated: 2015-09-17 09:40

Dependencies (3)

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

cocreature commented on 2012-05-06 07:28

It fails to build for me dew to autoconf not being recognized http://pastebin.com/sHAktpRC.

exterm commented on 2012-01-25 22:19

this shoud really be merged with gimp-resynth-git since all it does is fetch the newest git revision.

Anonymous comment on 2011-12-11 09:07

Of course change http://fenski.pl/gimp-resynth/PKGBUILG to http://fenski.pl/gimp-resynth/PKGBUILD in my first comment.

Anonymous comment on 2011-12-11 08:36

And diff for maintainer if he wants to include it in his PKGBUILD.

--- PKGBUILD.orig 2011-12-11 09:34:46.328498726 +0100
+++ PKGBUILD 2011-12-11 09:26:47.521812451 +0100
@@ -39,6 +39,8 @@

./autogen.sh
./configure --prefix=/usr
+ sed -i -e 's/GIMP_LIBS = -pthread/GIMP_LIBS = -pthread -lm/g' Makefile src/Makefile
make
}

Anonymous comment on 2011-12-11 08:29

Try my ugly hack to workaround it.
http://fenski.pl/gimp-resynth/PKGBUILG

mkdir gimp-resynth; cd gimp-resynth
wget http://fenski.pl/gimp-resynth/PKGBUILG
makepkg -s
sudo pacman -U gimp-resynth-1:20111211-1-x86_64.pkg.tar.xz

Anonymous comment on 2011-12-10 16:44

I tried to build the package using makepkg and got the following error:

gcc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wall -Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu -o resynthesizer resynthesizer.o -pthread -lgimpui-2.0 -lgimpwidgets-2.0 -lgimpmodule-2.0 -lgimp-2.0 -lgimpmath-2.0 -lgimpconfig-2.0 -lgimpcolor-2.0 -lgimpbase-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
/usr/bin/ld: resynthesizer.o: undefined reference to symbol 'atan2@@GLIBC_2.2.5'
/usr/bin/ld: note: 'atan2@@GLIBC_2.2.5' is defined in DSO /lib/libm.so.6 so try adding it to the linker command line
/lib/libm.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [resynthesizer] Error 1
make[2]: Leaving directory `/home/ewl/Desktop/resynth/src/resynthesizer-build/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ewl/Desktop/resynth/src/resynthesizer-build'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
It does recommend adding, I assume, /lib/libm.so.6 to the linker command line, but I'm not sure how to do that. I'd appreciate any help.
I'm using the x86_64 version of Arch on an Acer Aspire 7741z laptop. Everything else seems to be working fine, and I have compiled other packages without any problems.

Anonymous comment on 2011-09-15 17:58

The gimp org registry page does not provide a proper link to the source. As for autogen.sh, it's distributed, so I consider it to take precedence over the configure script.

Kwpolska commented on 2011-09-10 08:03

$url shall be set to http://registry.gimp.org/node/25219, and ./autogen.sh is not needed.

Anonymous comment on 2011-05-05 05:29

@t3ddy: I've added intltool, everything else is already implied (base-devel, glib2).

t3ddy commented on 2011-05-04 15:37

maybe you should add a few dependencies:

I am testing that you have the required versions of autoconf,
automake, glib-gettextize and intltoolize...

checking for autoconf >= 2.54 ... yes (version 2.68)
checking for automake >= 1.6 ... checking for glib-gettextize >= 2.0.0 ... yes (version 2.28.6)
checking for intltool >= 0.17 ...
You must have intltool installed to compile resynthesizer.
Get the latest version from
ftp://ftp.gnome.org/pub/GNOME/sources/intltool/