Warning: file_exists(): open_basedir restriction in effect. File(/srv/http/vhosts/aur.archlinux.org/public/web/locale//en/LC_MESSAGES/aurweb.mo) is not within the allowed path(s): (/srv/http/vhosts/aur-dev.archlinux.org/:/etc/aurweb/) in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/streams.php on line 90
AUR (en) - gimp-gtk3-git

Notice: Undefined variable: name in /srv/http/vhosts/aur-dev.archlinux.org/public/web/lib/pkgfuncs.inc.php on line 248

Package Details: gimp-gtk3-git 2.9.2.r933.gfc73b32-1

Git Clone URL: https://aur-dev.archlinux.org/gimp-gtk3-git.git (read-only)
Package Base: gimp-gtk3-git
Description: GNU Image Manipulation Program
Upstream URL: http://www.gimp.org
Licenses: GPL, LGPL
Conflicts: gimp-2.99
Provides: gimp-2.99
Replaces: gimp-2.99
Submitter: ksj
Maintainer: ksj
Last Packager: ksj
Votes: 13
Popularity: 1.028556
First Submitted: 2013-07-29 07:33
Last Updated: 2016-04-15 12:39

Dependencies (30)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Nordlicht commented on 2016-03-31 14:13

Information from Michael Natterer:

"Cool. Since you seem to be active there, can you tell them that
the following is wrong:

Conflicts: gimp
Provides: gimp
Replaces: gimp

gimp-3.x is completely parallel installable with gimp-2.x, nothing
conflicts, and it replaces nothing. It's a different thing with different
names for binaries, folders, libraries, everything."

Sounds legit.

haawda commented on 2016-03-31 11:17

Thank you for reporting. Not being at my Arch box right now, I cannot test myself right now, but will take your feedback as a green light for the bugreport.

Nordlicht commented on 2016-03-30 19:32

Works. Many thanks! :)

Edit: The branch is rebased. Works again without the workaround.

haawda commented on 2016-03-30 19:20

As a workaround: gimp-gtk3-git 2.9.2.r881.g2e8625b-1 builds against gegl-git backported to 0.3.6.31.gcb7dba0-1, i.e. with source=(git://git.gnome.org/gegl#commit=cb7dba07acf1e2edc4b79bd670c22dd1e1e6f965)

haawda commented on 2016-03-29 08:24

Bug Report filed, see https://bugzilla.gnome.org/show_bug.cgi?id=764304

Nordlicht commented on 2016-03-29 01:48

Same for me (errors at the beginning), I guess we have to wait for the bug fixes here.

haawda commented on 2016-03-28 23:58

Same build failures here, but at the beginning of the configure step I get

configure: WARNING: unrecognized options: --with-gif-compression, --with-libcurl, --without-hal, --without-gvfs, --without-gnomevfs

Nordlicht commented on 2016-03-28 16:41

FYI: If you're using Gnome 3.20 and Gimp is crashing when using some UI-elements (like the color-chooser): Change the gtk-theme. Seems as if the adwaita-theme is buggy atm (try gtk-theme-arc-git, that works fine here).

The actual code does not compile atm:

CCLD gimp-2.99
ar: `u' modifier ignored since `D' is the default (see `U')
core/libappcore.a(gimpparamspecs-duplicate.o): In function `gimp_param_spec_duplicate':
gimpparamspecs-duplicate.c:(.text+0x2fd): undefined reference to `GEGL_IS_PARAM_SPEC_MULTILINE'
collect2: error: ld returned 1 exit status
Makefile:926: recipe for target 'gimp-2.99' failed
make[4]: *** [gimp-2.99] Error 1
make[4]: Leaving directory '/tmp/makepkg/gimp-gtk3-git/src/gimp/app'
Makefile:1166: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/tmp/makepkg/gimp-gtk3-git/src/gimp/app'
Makefile:833: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/tmp/makepkg/gimp-gtk3-git/src/gimp/app'
Makefile:773: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/tmp/makepkg/gimp-gtk3-git/src/gimp'
Makefile:674: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Nordlicht commented on 2016-03-25 19:38

Is it just me, or are the themes/icon-themes not working? I've tried to select the symbolic-theme, but it is not beeing used.

ksj commented on 2016-03-14 21:09

That's right. Done.